User panel stuff on forum
  4 posts on 1 page  1
Help
2017-11-28, 12:12
Member
38 posts

Registered:
Jan 2006
Hey there!

I don't know how to use properly cl_proxyaddr, can someone explain me?

For example, when I connect to proxy and reconnect server, everything fine, the problem is to disable and connect without server.

I do cl_proxyaddr qw.playground.ru:30000 and reconnect. To disable I do cl_proxyaddr " " or even cl_proxyaddr 0, but when try to reconnect/connect to server always give me "bad server address". I even tried to use cl_useproxy 0/1 to disable/enable. I should be doing something wrong.

I wanted to make an alias to connect just with few words like:

alias pr0 "cl_proxyaddr 0; echo proxy disable!" or cl_proxyaddr " ";
alias pru "cl_proxyaddr qw.playground.ru:30000; echo proxy playground.ru on!"

I even did, and it was very bad since didn't worked out:

alias pr0 "cl_useproxy 0; cl_proxyaddr 0; echo proxy disable!"
alias pru "cl_useproxy 1; cl_proxyaddr qw.playground.ru:30000; echo proxy playground.ru on!"

Any of those, on /reconnect or /connect will give me "bad server address" after disable.
Example:
/pr0
/connect troopers.fi:28001
message: "bad server address"

I would be thankfull to be able to reconnect without several tried or /quit and re-enter and connect to server. Any idea what I'm doing wrong or how it works?

Also, what is the difference between /connect and /connectbr?
Not a Gamer!
2017-11-28, 12:30
Administrator
2039 posts

Registered:
Jan 2006
Not sure about the proxy stuff, but the difference between connect and connectbr is that the last one (connectbr = connect best route) automatically uses proxies to find the lowest ping to the server you try to connect to. You need to refresh the server browser in order for it to work though, or run sb_refresh in console. When connecting to a server via the server browser it automatically uses connectbr.
www.facebook.com/QuakeWorld
2017-11-28, 12:40
Member
271 posts

Registered:
Feb 2006
cl_proxyaddr 0 is invalid.
it'll then try connecting to "0" as a proxy before your real server. hence the bad address stuff. to disable the proxy stuff it MUST be an empty string.
I have absolutely no idea how to make an alias in ezquake that sets a cvar to the empty string, but you can try: alias foo "unset cl_proxyaddr; echo whatever" and hope that it ends up with the right value.

cl_useproxy is something else. Specifically, if you're connected to a qizmo proxy then it reuses the same proxy to connect to the new server. Otherwise it disconnects first. It has no affect on cl_proxyaddr.

connectbr attempts to figure out the 'Best Route' in an attempt to reduce your ping. Whether this actually works reliably is anyone's guess. It might result in higher packetloss, or lag bursts - more proxies = more chances for things to go wrong. That said, if all the calculated pings are reliable and consistent then its a win.
so if it works for you then you can skip cl_proxyaddr. otherwise have fun with configuring lots of manual routes...
moo
2017-11-28, 20:54
Member
182 posts

Registered:
Feb 2011
Right, as spike said the problem is your tried cl_proxyaddr " " instead of cl_proxyaddr "" (no space between quotes)
  4 posts on 1 page  1