User panel stuff on forum
  11 posts on 1 page  1
Advanced Configuration
2016-12-15, 00:08
Member
279 posts

Registered:
Jan 2015
Hello.

These past few days I dedicated my time to investigate my FPS drop problem. I play in a MacBook PRO running Windows 10, with all the most recent drivers of NVIDIA GT750M.

The original problem was caused by CPU / GPU throttling, few times because of temperature and few because of lack of enough power supply (this is a common problem on laptops that were not built specifically for gaming). I fixed this by disabling Turbo Boost and downclocking both CPU and GPU to level where I can have at least 693 fps (on maxfps 0 it shows 900-1100). So now, there is no throttling, which means that the CPU and GPU clocks are steady (throttling is a mechanism to prevent malfunction / damage by adjusting frequency to lower levels). I also do not have background processes stealing CPU (fixed that also).

After all this, I was supposed to get stable 693fps, right? Unfortunately I still get 2-6 frames lost, regardless if i use 693, 616 or 308 as maxfps, I will always loose some 2 to 6 fps here and there.

Does anyone have a clue what could be happening?

Things that I already checked / tried:

- Energy setting is on maximum performance on Windows and nVidia
- Thread Optmization off
dev
2016-12-15, 00:26
News Writer
884 posts

Registered:
Jan 2006
Have you tried Process Lasso?
2016-12-15, 00:50
Member
279 posts

Registered:
Jan 2015
dirtbox wrote:
Have you tried Process Lasso?


Yes. But I prefer Process Explorer.
dev
2016-12-15, 09:07
Administrator
1023 posts

Registered:
Apr 2006
Try sys_yieldcpu 0 if its not set.

Also make sure that threaded optimization is really off for everything, just so you didn't happen to turn it off for a specific binary. This is usually exactly what happens when threaded optimizations are on, I can't recall something else causing the same problem (except for sys_yieldcpu).
2016-12-15, 09:31
News Writer
884 posts

Registered:
Jan 2006
dimman wrote:
Also make sure that threaded optimization is really off for everything, just so you didn't happen to turn it off for a specific binary. This is usually exactly what happens when threaded optimizations are on, I can't recall something else causing the same problem (except for sys_yieldcpu).


Are you talking about nvidia or cpu? if so, how do you do it on cpu?
2016-12-15, 10:08
Member
279 posts

Registered:
Jan 2015
dimman wrote:
Try sys_yieldcpu 0 if its not set.

Also make sure that threaded optimization is really off for everything, just so you didn't happen to turn it off for a specific binary. This is usually exactly what happens when threaded optimizations are on, I can't recall something else causing the same problem (except for sys_yieldcpu).


I switched all on and off several times with reboot. Didnt fix it.

sys_yieldcpu was always 0.

I'll try ezq 2.2 later on.

Edit: same problem on ezQuake 2.2 (no surprise).
dev
2016-12-15, 18:27
Administrator
1023 posts

Registered:
Apr 2006
andrestone wrote:
dimman wrote:
Try sys_yieldcpu 0 if its not set.

Also make sure that threaded optimization is really off for everything, just so you didn't happen to turn it off for a specific binary. This is usually exactly what happens when threaded optimizations are on, I can't recall something else causing the same problem (except for sys_yieldcpu).


I switched all on and off several times with reboot. Didnt fix it.

sys_yieldcpu was always 0.

I'll try ezq 2.2 later on.

Edit: same problem on ezQuake 2.2 (no surprise).

Tried other gfx drivers?

@dirtbox: Threaded optimizations is an nvidia thing for their gpu's.
2016-12-15, 22:27
Member
279 posts

Registered:
Jan 2015
dimman wrote:
andrestone wrote:
dimman wrote:
Try sys_yieldcpu 0 if its not set.

Also make sure that threaded optimization is really off for everything, just so you didn't happen to turn it off for a specific binary. This is usually exactly what happens when threaded optimizations are on, I can't recall something else causing the same problem (except for sys_yieldcpu).


I switched all on and off several times with reboot. Didnt fix it.

sys_yieldcpu was always 0.

I'll try ezq 2.2 later on.

Edit: same problem on ezQuake 2.2 (no surprise).

Tried other gfx drivers?

@dirtbox: Threaded optimizations is an nvidia thing for their gpu's.


You mean older versions?

I'll try.
dev
2016-12-16, 17:43
Member
36 posts

Registered:
May 2012
Hi dev,
things i would check furthermore,

networkshares or some streaming services on your computer?

having two monitors attached leads to performance drops of 2-5 frames like this for me somehow, (it was enough to go to nvidia settings - multi monitor setup - uncheck the unused monitor).

if you would use windows, i'd say open some kind of latency monitor software and check if that FPS drop is visible in latency monitor as spike aswell. Maybe you find a mac alternative latency monitor.

buffer overflow? s_desiredsamples high enough? No issue here? Sounddriver buffer fine? Next step try lowering mouse hz to 500 if you can. and so on..

lastly reinstall qw from scratch. Download just the needed pak files, grab ezquake.exe, and try on a nonnquake installation (I have seen textures fuck up!).
2016-12-17, 11:47
Member
238 posts

Registered:
Jan 2006
There's a option in nvidia control panel to set performance to maximum all the time - try that
2016-12-20, 20:19
Member
279 posts

Registered:
Jan 2015
Older driver solved the problem.

Thanks everyone.
dev
  11 posts on 1 page  1