User panel stuff on forum
  9 posts on 1 page  1
Client Talk
2016-12-05, 09:12
Member
25 posts

Registered:
Jun 2006
Hi

I have installed ubuntu 16.04 and got ezquake 2.2 32bit. (The pc is rather old )
Turned refresh rate of samsung rz 2233 to 120 hz and show_fps returns maximum 120 fps.
When i had 60 hz refresh then show_fps returned max 60 fps
Seems like i cant get more fps than the refresh rate of monitor?
Tried different configs of fellow quakers and all variables of cl_physfps, independentphysics and so on and max returned of show_fps is 120 .
Timerefresh gives me above 1,5k fps.
I have ati radeon 4870 graphic card - the drivers are those build in ubuntu.
Is this the drivers fault, or there is a secret and misterious command such as vid_do_me_good 1 ?
Cheers
2016-12-05, 10:19
News Writer
102 posts

Registered:
Sep 2014
/vid_vsync 0

Have you tried that?
2016-12-05, 10:23
Member
25 posts

Registered:
Jun 2006
yup - and it doesn't do the trick
2016-12-05, 11:21
Administrator
1022 posts

Registered:
Apr 2006
Try

vblank_mode=0 ./ezquake-gl.glx

and see if it helps.

Also note that ezQuake 2.x is no longer supported. I recommend you to upgrade to v3 as it's a major upgrade for Linux users. You'll probably get better performance too (although not as good as it could be, but I'm planning on looking into that in the future)
2016-12-05, 11:35
Member
25 posts

Registered:
Jun 2006
thanks dimman ill try it tonight
can you tell me where can i download 32 bit version of ezq v3 ?
2016-12-05, 15:51
Administrator
1022 posts

Registered:
Apr 2006
blsp wrote:
thanks dimman ill try it tonight
can you tell me where can i download 32 bit version of ezq v3 ?

For Linux I recommend building it from sources (see the COMPILING_ON_LINUX.txt in the repository).
2016-12-05, 20:08
Member
25 posts

Registered:
Jun 2006

vblank_mode=0 ./ezquake-gl.glx
it doesnt work and i also have this thing returned in terminal:
ATTENTION: default value of option vblank_mode overridden by environment.
2016-12-07, 09:59
Administrator
1022 posts

Registered:
Apr 2006
blsp wrote:

vblank_mode=0 ./ezquake-gl.glx
it doesnt work and i also have this thing returned in terminal:
ATTENTION: default value of option vblank_mode overridden by environment.

Ok, then I think you'll have to add this

Option "SwapbuffersWait" "false"



to your Xorg configuration file for the card.

Try googling it and I think you'll find exact details on how to do it for your Ubuntu version and AMD card.
Fairly sure that will solve it.
2016-12-07, 11:43
Member
25 posts

Registered:
Jun 2006
thank you for your help
it seems my attitude "linux - ez" was a mistake
i apologized whole system, and started from the beginning - ubuntu manual \

EDIT:
Ubuntu 16.04 hand wrong drivers for my pc ( there was some hardware problem) so i switched to linux mint mate coz i got rather old pc.
And in that distribution everything works fine
That fps problem was solved by vblank_mode=0
Thanks dimman.
  9 posts on 1 page  1