User panel stuff on forum
  9 posts on 1 page  1
Server Talk
2015-02-17, 12:38
Member
7 posts

Registered:
Feb 2015
Hello,

I have been trying to set up a FFA server for some time now but it just wont work.

Im using the nQuakesv install and i am successfully running 4 KTX team servers and i am running an old rocket arena server but the FFA server wont work.

I have tried to modify the config files in all kinds of ways and still it wont work.

My plan is to have these servers running 24/7 on my server that i just upgraded so if anyone can help me wiht the FFA server i would be thankfull.

My other servers are the Shadwos servers found in the serverlist.
2015-02-17, 14:59
Member
256 posts

Registered:
Feb 2006
Hi,

Does nQuakesv or MVDSV output some error when you try to start the FFA server?
2015-02-18, 07:06
Member
7 posts

Registered:
Feb 2015
The server starts and everything but the problems is that the only setting that seems to be correct is the matchelss setting.
No other settings work.

I cant get the maproatation to work.
I cant set the DMM.
I cant set the fraglimit.

It seems like no matter what i try to change in the configs it wont work.
2015-02-18, 15:05
Member
256 posts

Registered:
Feb 2006
k_matchless "1" should do the trick.

I just did a fresh install of nQuakesv and changed k_matchless to 1 in ktx/port1.cfg. After restarting the server port 1 was running FFA in matchless mode where players do not need to type ready for the match to start.

There is also matchless.cfg which has map rotation but I'm not sure when it gets executed. Ktx/configs/usermodes/matchless/default.cfg should get executed on every map change when server is in matchless mode.
2015-02-18, 16:06
Member
7 posts

Registered:
Feb 2015
Yes as i said previously matchless is the only setting that works.

I cant get anything else to work and i have tried editing in all configs possible.

What i want is a FFA server with teamplay 0 and DMM3, timelimit 20, fraglimit 50 and a good maprotation.

The server must be able to run on windows 8.1 and it does not nessesary to be using the nQuakesv pack.

The rocket arena sever i am running i am using the old QWSV version but as i dont have a FFA gamedir and dont know how to set that up i cant use that.
2015-02-18, 17:19
Administrator
2047 posts

Registered:
Jan 2006
See if the following helps:

In \nQuakesv\shortcuts i have a shortcut called "ffa 27500" (not sure if this is standard or created by myself long ago?) with following commandline:
mvdsv.exe -port 27500 -game ktx +exec port1.cfg +exec matchless.cfg

I can change settings of this server by editing the following file:
\nQuakesv\ktx\configs\usermodes\matchless\default.cfg

In there i added:
timelimit 2
fraglimit 50
deathmatch 3

And timelimit is now changed to two minutes when i enter the server. I noticed i had a matchless.cfg in /nquakesv/ktx/ directory but that one doesn't seem to get executed as those settings don't take effect when changing them...
www.facebook.com/QuakeWorld
2015-02-18, 17:23
Member
256 posts

Registered:
Feb 2006
Deatchmatch is set to 3 automatically when server is in matchless mode. Timelimit, fraglimit and map rotation can be set in ktx/configs/usermodes/matchless/default.cfg. If you want the first map of the rotation to be for example dm2 you should add "map dm2" to ktx/port1.cfg so the server enters the rotation when it is started.

I've just tested all of this so it should work.
2015-02-18, 19:43
Member
7 posts

Registered:
Feb 2015
i will make some new tests tomorrow and see if i canget it to work.

ill post back here with the results
2015-02-19, 08:20
Member
7 posts

Registered:
Feb 2015
Now i got it working.

I was able to get it working editing the default.cfg located in nQuakesv/ktx/configs/usermodes/ffa

Thanks for all the help.
  9 posts on 1 page  1