User panel stuff on forum
  4 posts on 1 page  1
Client Talk
2013-11-02, 12:24
Member
338 posts

Registered:
Feb 2006
I really don't know if this is a Mavericks issue or not. But I got a problem with a dead zone in ezQuake.

The error doesn't appear on desktop, and not in the Mac build of Darkplaces. It's also present in ezquake if I erase the config.cfg and run default. The error isn't in PC build when I run it in Win7 via Parallels.

The issue is if I move my ME3.0 Mouse or Trackpad very slow. The crosshair doesn't move at all. Like some deadzone at a specific low mouse speed. I can move the mouse from one end of the mousemat to another. Without moving in ezQuake. Is this a known issue? Or can it be dealt with?
ProjectQ1Q3, Frogbot Waypoint and Map Conversion Tutorial @ http://mickkn.mooo.com
2013-11-02, 12:43
Member
340 posts

Registered:
Nov 2006
What is the sensitivity set at? It might be due to a rounding error in the code resulting in the movement being ignored. Don't know how Darkplaces works here - but there are several APIs in OS X where the mouse input can be gotten from. So maybe they are smarter than the code found in ezQuake.

Can you check if the problem exist with Fodquake? If it does I may take a look for a cause and for a potential fix. For ezQuake.. not so much :[
2013-11-02, 14:26
Member
338 posts

Registered:
Feb 2006
Okay, did some testing and the Client can't handle Sens values below 1 I guess

I was running 0.89 with my custom yaw/pitch values and changed it to 1 with the problem solved
ProjectQ1Q3, Frogbot Waypoint and Map Conversion Tutorial @ http://mickkn.mooo.com
2013-11-02, 19:55
Administrator
1024 posts

Registered:
Apr 2006
Tuna wrote:
What is the sensitivity set at? It might be due to a rounding error in the code resulting in the movement being ignored. Don't know how Darkplaces works here - but there are several APIs in OS X where the mouse input can be gotten from. So maybe they are smarter than the code found in ezQuake.

Can you check if the problem exist with Fodquake? If it does I may take a look for a cause and for a potential fix. For ezQuake.. not so much :[

Not entirely true, a SDL2-unified-backend version is in the works
  4 posts on 1 page  1