User panel stuff on forum
  18 posts on 1 page  1
General Discussion
2011-08-25, 10:45
Member
93 posts

Registered:
Apr 2006
I recently got a new HDD drive and reinstalled a fresh copy of Windows XP onto it. I saved my old quake dir and copied it onto my new disk. I am having lag issues in quakeworld in gl mode only. Every 2 or 3 seconds there is a lag constantly. I am using a Nvidia gt 7800 gfx card with latest drivers and have run all windows updates, active x, direct x. Sw works fine, gl ez/fuh clients lag.

I have had this problem before and I cannot remember how I fixed it

Can anyone think of some suggestions please?
2011-08-25, 10:55
Administrator
328 posts

Registered:
Jan 2006
What harddrive? SSD? if not - get it =D
Windows XP? get windows 7!
ready!
2011-08-25, 11:06
Member
93 posts

Registered:
Apr 2006
ParadokS wrote:
What harddrive? SSD? if not - get it =D
Windows XP? get windows 7!

Thanks for the help!

I need to upgrade my pc, its like 6 years old?

I tried to install windows 7 and it took about 84 hours to install and then about a week to get into windows once it was done
2011-08-25, 11:33
Administrator
1261 posts

Registered:
Jan 2006
try to install a new version of quake, maybe nquake.
try it without your config
try cfg_reset and vid_restart
try fodquake

also, try installing older nvidia drivers.
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2011-08-25, 11:49
Administrator
1024 posts

Registered:
Apr 2006
Do: nVIDIA settings -> 3D settings or something like it -> Threaded Optimization OFF

Your welcome
2011-08-25, 13:19
Member
93 posts

Registered:
Apr 2006
dimman wrote:
Do: nVIDIA settings -> 3D settings or something like it -> Threaded Optimization OFF

Your welcome

you sound confident old chap!

Thanks all, will try when I get home!

Need a new pc really .
2011-08-25, 17:35
Member
93 posts

Registered:
Apr 2006
mushi wrote:
try to install a new version of quake, maybe nquake.
try it without your config
try cfg_reset and vid_restart
try fodquake

also, try installing older nvidia drivers.

done, no help.
2011-08-26, 09:34
Administrator
1024 posts

Registered:
Apr 2006
serox wrote:
dimman wrote:
Do: nVIDIA settings -> 3D settings or something like it -> Threaded Optimization OFF

Your welcome

you sound confident old chap!

Thanks all, will try when I get home!

Need a new pc really .

Yeah well I figured since it works fine in software its very unlikely network-related or something like that.

Have you tried setting Threaded optimization to Always off yet?
2011-08-29, 15:30
Member
93 posts

Registered:
Apr 2006
dimman wrote:
serox wrote:
dimman wrote:
Do: nVIDIA settings -> 3D settings or something like it -> Threaded Optimization OFF

Your welcome

you sound confident old chap!

Thanks all, will try when I get home!

Need a new pc really .

Yeah well I figured since it works fine in software its very unlikely network-related or something like that.

Have you tried setting Threaded optimization to Always off yet?

yes i tried it, no difference! anything else?
2011-08-30, 08:44
Administrator
1024 posts

Registered:
Apr 2006
Install new motherboard drivers and network drivers, thats about what I can think of atm.

Both of them has caused similair issues for me, even if its strange that the software version works fine.
2011-08-30, 09:09
Member
459 posts

Registered:
Mar 2008
Yo Chris :-)

Have you tried to optimize your Windows yet? By that I mean removing all services at startup except those needed to run EzQuake in gl-mode. I also experienced some random lag at times until I ran a registry file that removed lots of random services that follows with a fresh install of XP.

Also run Windows Update to get all the latest important updates (important: do NOT update nVIDIA drivers from windows update).

Also do a registry check and check if any spyware is lurking around, by downloading Search & Destroy or AdAware.

There might also be some issue with older nvidia cards with the newest driver running OpenGL applications, but I don't know anything about that.

If its not any of the things listed here already, then theres probably some overheating issue with your processor or graphics card, caused by bad air circulation, malfunctioning fan, or similar.

GL getting it solved!
2011-08-31, 00:09
Member
218 posts

Registered:
Mar 2007
If the OP was running Vista or Win7 I would guess its the power-saver settings. I got burned by this years ago when Vista came out and I was tinkering with the power stuff... made games unplayable if you messed with the cpu settings enough.

Since he says it's XP, it could be similar settings in the motherboard BIOS. Some boards have settings that scale the CPU up and down according to demand, might wanna give it a look.
2011-09-02, 10:24
Member
93 posts

Registered:
Apr 2006
dimman wrote:
Install new motherboard drivers and network drivers, thats about what I can think of atm.

Both of them has caused similair issues for me, even if its strange that the software version works fine.

I am thinking the same tbh.

I had trouble finding the drivers in the first place because the board is so old lol
2011-09-02, 10:25
Member
93 posts

Registered:
Apr 2006
Rikoll wrote:
Yo Chris :-)

Have you tried to optimize your Windows yet? By that I mean removing all services at startup except those needed to run EzQuake in gl-mode. I also experienced some random lag at times until I ran a registry file that removed lots of random services that follows with a fresh install of XP.

Also run Windows Update to get all the latest important updates (important: do NOT update nVIDIA drivers from windows update).

Also do a registry check and check if any spyware is lurking around, by downloading Search & Destroy or AdAware.

There might also be some issue with older nvidia cards with the newest driver running OpenGL applications, but I don't know anything about that.

If its not any of the things listed here already, then theres probably some overheating issue with your processor or graphics card, caused by bad air circulation, malfunctioning fan, or similar.

GL getting it solved!

hey rik


optimize windows xp how exactly?


windows update is all done and virus checking is clean. The pc has not moved location, all hardware is the same really so I dont think it is bad air circ tbh.
2011-09-02, 10:26
Member
93 posts

Registered:
Apr 2006
5h17h34d wrote:
If the OP was running Vista or Win7 I would guess its the power-saver settings. I got burned by this years ago when Vista came out and I was tinkering with the power stuff... made games unplayable if you messed with the cpu settings enough.

Since he says it's XP, it could be similar settings in the motherboard BIOS. Some boards have settings that scale the CPU up and down according to demand, might wanna give it a look.

good idea. I thnink i rem a few default settings for the bios, different modes etc.
2011-09-04, 17:38
Member
518 posts

Registered:
Jan 2006
if you reinstall windows it won't change anything in the bios
2011-09-05, 08:47
Administrator
1024 posts

Registered:
Apr 2006
My qualified guess is that in 99% of the cases the problem ain't BIOS-related.
2011-09-05, 14:44
Member
3 posts

Registered:
Sep 2011
give this a try,

in the device manager, right click the Primary IDE Channel and choose properties
then choose the Advanced Settings tab

make sure the Transfer Mode is set to DMA if available and make sure the Current Transfer Mode is one of the
Ultra DMA Modes. If it is in PIO Only Mode you have found the problem.

If it is indeed running in PIO Only mode, try changing the Current Transfer Mode to DMA if available and restarting.
If this is not possible (greyed out for example) the only other choice is to DELETE the Primary IDE Channel (yes, not kidding)
then reboot the machine and let it re-detect the channel. It will require a restart after this.

been lurking here for a while and saw this thread....decided to sign up.

Hope this helps

note: if this problem recurrs, which it sometimes does, the proper mainboard drivers as someone mentioned above should
fix this long term.
  18 posts on 1 page  1