User panel stuff on forum
  33 posts on 2 pages  First page12Last page
Advanced Configuration
2009-10-24, 17:31
Member
61 posts

Registered:
Jan 2006
If and when you get lag spikes while playing just disable multimedia class scheduler from services (click start - run and services.msc). You can also remove it from registry HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Audiosrv and in the DependOnService remove mmcs just to make sure it's really turned off (start - run - regedit).

This fixed the main problems with ping but I still have some random spikes like one in 5-10mins. If anyone know what service causes that please write here.

Anyways Windows 7 feels really good even with qw... so I recommend this Windows if you need to install a new one.
2009-10-24, 18:16
Member
42 posts

Registered:
Apr 2007
I got this fix from diki earlier and it works perfectly, i don't have the second problem that diki has. Besides that you have to disable that service Windows 7 i a really nice OS.
http://www.rocketz.se - a quakeworld blog in the 21st century
2009-10-24, 19:36
Member
518 posts

Registered:
Jan 2006
default isntall works perfect for me don't need to disable anything
2009-10-24, 19:58
Member
55 posts

Registered:
Jan 2009
Same here. Altho im running some oldish RC.. Windows 7 is the only OS that gives me stable 1000hz usb polling rate (i've tried Win xp sp2/3 and linux). So if you have trouble with that give win 7 a go.
2009-10-24, 20:29
Member
125 posts

Registered:
Jan 2008
Oh snap! I who thought it ess my crappy isp Messing with Me
2009-10-24, 20:32
Member
370 posts

Registered:
Mar 2008
Lag spikes? I use the win 7 RC and no problems...
2009-10-25, 09:53
Member
371 posts

Registered:
Dec 2006
Are you using wireless? If so the lag spikes may be caused by polling done by the Windows wireless service, where you get 100% pl for very short periods.
2009-10-25, 10:47
Member
42 posts

Registered:
Apr 2007
HangTime wrote:
Are you using wireless? If so the lag spikes may be caused by polling done by the Windows wireless service, where you get 100% pl for very short periods.

Nope, using cable.
http://www.rocketz.se - a quakeworld blog in the 21st century
2009-10-25, 13:50
Administrator
1023 posts

Registered:
Apr 2006
Your welcome Diki! Yeah there is another thing one can turn off, just happend to forget it atm, ill get back to it later when i get home.

Btw, the reason for making the change in the registry is that you probably are unable to stop the service, because the Audioservice for some reason depends on the mmcs-service. So first remove it from the list in registry, then stop and disable service, then reboot.

I got problems with Realtek drivers on win7, using the default that came with windows now without problems. So if you have realtek and installed their own drivers, try to do a driver rollback or uninstall the driver and let windows use its own.
2009-10-25, 17:55
Member
61 posts

Registered:
Jan 2006
There is no that problem with beta versions... I had it too.

-And thanks Fog

-I'm not using wireless.
2009-10-25, 17:57
Member
462 posts

Registered:
Jan 2006
Yeah ihminen had the same prob and when we disabled that service the ping was fine.
2010-09-22, 01:46
Member
61 posts

Registered:
Jan 2006
Hehe... what if you just read the first post and try that? Im quite sure it will solve the problem.
-remove mmcs from registy and services
2010-09-22, 18:21
Member
53 posts

Registered:
Feb 2008
it cound be a antispy prog ? nortons and mcafee gave me problems in the pass
2010-10-13, 07:56
Member
22 posts

Registered:
Oct 2010
Diki: Thank you for this!! Worked like a charm!
2010-10-14, 17:05
Member
23 posts

Registered:
Jan 2006
Try this

* Open regedit
* Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile
* There will be an entry for network performance throttling, default value is 10; set it to FFFFFFFF hex (willl look like 0xFFFFFFFF to the right of the entry)
* Reboot
2010-10-14, 17:09
Administrator
1023 posts

Registered:
Apr 2006
TheEvilDog wrote:
Try this

* Open regedit
* Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile
* There will be an entry for network performance throttling, default value is 10; set it to FFFFFFFF hex (willl look like 0xFFFFFFFF to the right of the entry)
* Reboot

I got some really unpleasant lag from that one. Would not go for it unless really necessary and nothing else helps. Or well, no harm to try it out ...
2010-10-14, 19:14
Member
1433 posts

Registered:
Jan 2006
Removed the DoD:S spammer who posted here few posts before.
2010-10-15, 08:19
Member
22 posts

Registered:
Oct 2010
http://hem.bredband.net/b206185/W7_ping_fix.jpg

In-game ping Before and After I disabled Multimedia Class...
2010-10-15, 13:04
Member
284 posts

Registered:
Oct 2006
heddan wrote:
http://hem.bredband.net/b206185/W7_ping_fix.jpg

In-game ping Before and After I disabled Multimedia Class...

Hey,

Can you confirm that your ping fluctuated that much _always_? I'm just trying to determine whether my own lagging could be caused by that, but as it's not constant, I kinda doubt it.

It's just that seeing that picture really connected this issue to the kind of spiking I have at times. Mostly good ping, but it spikes up to 40ms very quickly and quite rapidly.
2010-10-20, 08:32
Member
22 posts

Registered:
Oct 2010
niomic: Yes, The ping was constantly spiking... I noticed that my diagram was a bit missleading in its current form since the "spikes" were one at a time... I think bars would have shown the issue in a better/more correct way. Anyway... The issue only happens when I am connected to a server in quake... and is in the game (i.e. not tabbed out) so, just try to do a "ping -t pangela.se >c:\test1.txt" or something and try to play a game... and then quit quake and do a new ping log towards pangela while in windows for 10 minutes... And then compare the logs in excel.
2010-10-21, 08:06
Member
1433 posts

Registered:
Jan 2006
Seems like it's a pretty old issue. Thanks to itmik for pointing me to this:
http://blogs.technet.com/b/markrussinovich/archive/2007/08/27/1833290.aspx
2011-01-02, 01:07
Member
1 post

Registered:
Jan 2011
Run services.msc
Go down to WLan Autoconfig
Right click and go to properties
Change automatic to manual

Worked for me, and I figure because its on manual, its not constantly checking like it once was, and if you want a better connection you do it yourself now. Hence the manual part.
2011-03-04, 10:31
Administrator
1023 posts

Registered:
Apr 2006
Heh, and that is different from the first post how?
2011-03-04, 21:32
Administrator
1857 posts

Registered:
Feb 2006
Hmm, I'm gonna take a wild shot and classify that as a spam post... He is gone now atleast
2011-10-07, 10:14
Member
693 posts

Registered:
Jan 2006
Aha!
2011-11-03, 22:45
Member
685 posts

Registered:
Jul 2007
Can ppl pls post their version of win7 pls.... Makes it easier to tell which version gives the most/least problems. I'm using Home Premium x64 and it's stuttering like crazy.
2011-11-03, 23:33
Member
685 posts

Registered:
Jul 2007
iobit game booster solved it
2011-11-19, 22:15
Member
4 posts

Registered:
Sep 2011
megalodon wrote:
iobit game booster solved it

I installed it but my windows 7 is still laging. Lowest ping I can get is 30-40 plus some PL can anybody help? Any of above methods doesn't work! I'm using windows 7 ultimate.
2011-11-20, 20:42
Administrator
1023 posts

Registered:
Apr 2006
Corleone wrote:
megalodon wrote:
iobit game booster solved it

I installed it but my windows 7 is still laging. Lowest ping I can get is 30-40 plus some PL can anybody help? Any of above methods doesn't work! I'm using windows 7 ultimate.

Thats probably because of your ISP then, and not "lag spikes".
2011-11-20, 21:51
Member
4 posts

Registered:
Sep 2011
dimman wrote:
Corleone wrote:
megalodon wrote:
iobit game booster solved it

I installed it but my windows 7 is still laging. Lowest ping I can get is 30-40 plus some PL can anybody help? Any of above methods doesn't work! I'm using windows 7 ultimate.

Thats probably because of your ISP then, and not "lag spikes".

Well possibly because my broadband but I don't think so as it is 20mb fast so that should be enough to get decent ping? Such as 10-20. Lowest I can get now is 30-40 + PL so I'm lagging a lot. I think problem is in settings of probably Win7 + plus antivirus + tune up utilities.

I'm using Windows 7 64bit Ultimate + NOD32 + TuneUpUtilities. Game booster doesn't help either. Anybody?
  33 posts on 2 pages  First page12Last page