User panel stuff on forum
  49 posts on 2 pages  First page12Last page
Team Fortress
2007-07-09, 20:14
Member
785 posts

Registered:
Mar 2006
Mercury sent me today the source code of OZTF 1.76 Beta.

Attending to mercury's will, I'll not provide a link to download the files, instead of it, I'll send the files to people interested in keep mercury's work or to anyone that want to develop his own mod.

When I was contacting mercury, I asked him for a copy of the old OZTF 1.45 and for the last one as well. But he sent me only the files from 1.76 last beta, 1.13 and 1.22. So I guess he no longer has the 1.45 files. And as far as I know, this beta is far improved, comparede to the 1.76 beta release earlier from mercury him self. But it's not compilable in it's actual form. So if you wanna make a new OZTF version, be prepared to do a lot of hard work.

Mercury also sent me two other packs and for this packs I'm providing links. The first is a compiled copy of 1.76 beta (I don't know if it's the same old one) and a pack with GFX.


OZTF Beta

GFX - Special gift from mercury


PS.: I'm posting this thread here for the saking of publicity - but I think it should be moved to TF section in a few days!

tnx

PS2.: people interested in the code, should send me a PM with e-mail address.
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-10, 08:54
Member
159 posts

Registered:
Jun 2007
thanks veg. merc sending to me aswell.

TF LIVES!
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-10, 09:36
Member
1011 posts

Registered:
Feb 2006
hmm, with no specific license (well, a polite courtesy license) in place how does this work for future authors?

i.e., if someone updates oztf and makes new stuff, they can presumably release the source code - in the end it was originally based on qwtf so inherits the original 'do what you want' quakec license

p.s. please send me the source
2007-07-10, 14:21
Member
7 posts

Registered:
Apr 2007
vege just post it public, I think you misunderstood what I meant. I said as long as im not resposible I dont care, I am more then happy if someone decent could work on it.

And yes the source was given to me in full confidence that I wouldnt just make give it to anyone, that is what I mean by not being resposible :/

If you need to ask any questions about the source ask.
2007-07-11, 18:35
Member
159 posts

Registered:
Jun 2007
tried hosting an OZTF 1.76 server but encountered an error I cant seem to get past.

everything goes smoothly and I am able to connect, but once in the map I am unable to choose a team, it puts me straight into observer mode, and a message is displayed in the console:

Quote:
Client version illegal!
Please update your client to the latest FuhQuake, FTE or GreyMquake clients.

FuhQuake client available at... etc

Observer
Client version: ezQuake 1917

mercury pointed out to me that with OZTF 1.76 there is a new localinfo: ban_oldclient. i've tried setting this to:

localinfo ban_oldclients "off"
localinfo ban_oldclients "0"

but neither of these are able to do the trick and im still getting the error. any suggestions?
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-11, 19:04
Member
785 posts

Registered:
Mar 2006
Remove the code that block clients!
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-11, 20:07
Member
785 posts

Registered:
Mar 2006
This is a link for OZTF 1.76 without client check. And there's a bug probably regarding halflife and Q3 ents/maps and the new versions of MVDSV. Cause if you try to run a OZTF server with the new versions of MVDSV, it will always crash. But when I removed the halfife and Q3 stuff, the server ran fine (or you can use a old MVDSV)!

DOWNLOAD
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-12, 01:52
Member
159 posts

Registered:
Jun 2007
how do i compile this? or could you provide a link to your already compiled server?
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-12, 05:04
Member
159 posts

Registered:
Jun 2007
i tried to compile this using FrikQCC. Got an error:

error: Q505: items.qc:873:Unknown value "WEAP_NAILGUN"

know where I am going wrong?
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-12, 06:39
Member
159 posts

Registered:
Jun 2007
ok heres what i tried: this is really getting frustrating.

i used the oztf 1.76 source files that mercury sent me (probably the same he sent you vegetous). i read his READ ME FIRST OK.txt which explained that the files must be compiled using the included fteqcc using the makegui.bat. so i copied your updated .qc and progs.src without the client check and half-life / q3 stuff over the top of mercury's existing files and compiled.

then i tried to host a server. the first difference i noticed from when hosting the original oztf 1.76 server, is that i was required to have a file called shell.mdl. not finding this anywhere on my pc, i made a copy of shell2.mdl, renamed it shell.mdl, and connected.

everything went rather smoothly. i was able to choose a team, but then when i chose a class (soldier) the server crashed and reported:

CALL2 390(strcat)strcat()

whatever that means?

think you might point me in the right direction, or perhaps just send me your already compiled and working file?
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-12, 07:38
Member
785 posts

Registered:
Mar 2006
- Use last fteqcc to compile the source (use fteqccgui, it's very simple);
- Do not put "my files" over mercury's ones, use a separated folder to it;
- Use a old version of mvdsv to run the server (the version I'm using is *qwe_version 0.177 - *version 2.40)
- I do not removed halflife/q3 stuff, that's why you'll have to use a old MVDSV.
- There's a ready to run copy of oztf I'm working on for the TF brazilian community in this LINK
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-12, 08:00
Member
7 posts

Registered:
Apr 2007
q3 map support i made was for FTE client server.

Ignore it for mvdsvr shouldnt affect it its only entity support so if you load a q3 or et map it should load entities.

Dont use friqcc to compile it wont work fteqcc only.
2007-07-12, 08:22
Member
159 posts

Registered:
Jun 2007
http://fabianodolabella.oi.com.br/oztf_1_76b.rar is down.

also where can i get a copy of previous mvdsv versions? the files at http://quakeworld.ru/files/vvd/mvdsv/ are either corrupted, or completely missing the .exe file.
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-12, 08:29
Member
785 posts

Registered:
Mar 2006
I just tested a lot of MVDSV versions and this error only happens with the last version (0.26)!
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-12, 08:30
Member
785 posts

Registered:
Mar 2006
zel wrote:
http://fabianodolabella.oi.com.br/oztf_1_76b.rar is down.

No, it's not! But your IP is probably blocked! Try to use a proxy!
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-12, 08:37
Member
159 posts

Registered:
Jun 2007
right you are, finally got it to download. sorry.

also where can i get a copy of previous mvdsv versions? the files at http://quakeworld.ru/files/vvd/mvdsv/ are either corrupted, or completely missing the .exe file.
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-12, 08:55
Member
785 posts

Registered:
Mar 2006
http://sourceforge.net/project/showfiles.php?group_id=118599

There's a version inside the pack of 1.76b. If you need to host a server, I can send the 0.25 version to you. Do not use very old versions in public servers, they have a lot of exploitable bugs!
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-12, 09:11
Member
159 posts

Registered:
Jun 2007
yep i compiled your oztf 1.76 without client check, and ran on my own server with that really old server version included in your bundle, and it works ok, but yeah i would like to use the latest possible version.

vegetous could you send me 0.25?

email: shayolden [at] hotmail [dot] com
irc: irc.enterthegame.com #oztf
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-12, 09:15
Member
7 posts

Registered:
Apr 2007
ok i found things in the source which wont work for mvdsv. 1 the client connect code wasnt finished properly. 2 the builtins I must have changed them to suit fte servers. Ill see if i can get it working with mvdsvr and ill rezip the files
2007-07-12, 09:18
Member
785 posts

Registered:
Mar 2006
Tnx mercury!

PS.: zel, the source I released is the exact same thing mercury sent me, without client block. The compiled version isn't! It has changes in the hwguy armor and sniper reload time.

PS2.: what 0.25 version do you need? (win32 or Linux GLIBC 2.5 i386)
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-12, 09:26
Member
159 posts

Registered:
Jun 2007
merc: hero.

vege: sounds like your hard at work then vegetous! thats good news. i know you probably already are, but please document your changes? otherwise im certain well end up with oztf version floating around everywhere, and no way to tell whats what.

PS. win32 please vegetous

PPS. how fun is technician!
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-07-12, 09:42
Member
7 posts

Registered:
Apr 2007
well the builtins look fine so Im not sure why but the new mvdsv doesnt like 1.76 I assume its one of the changes theyve made. I havent got time to figure it out now but the builtins look ok.
2007-07-12, 20:57
Member
785 posts

Registered:
Mar 2006
Mmercury,

Is there anything in the source of oztf to control bunny-hoop? Guys from TF community are saying to me that such thing exists and I'm telling them that I don't think so!
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-12, 21:20
Member
37 posts

Registered:
Mar 2006
gspeed will control bunnyhop
2007-07-12, 23:01
Member
785 posts

Registered:
Mar 2006
When a player sets gspeed, is he setting for himself only or to all players? In the second case, is there a way to disallow players from setting it?

thx
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-13, 01:14
Member
785 posts

Registered:
Mar 2006
Btw

gspeed does not control bunny hoop speed! It stops the bunny once you reach the top limit.
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
2007-07-14, 03:05
Member
7 posts

Registered:
Apr 2007
gspeed does control bunny hop not perfectly but it works well. It checks ground speed on landing and adjusts it accordingly. You can set gspeed anything u want. ie if u set it to 2, it will be 2 times the maxspeed of any class. If you want to get rid of bunny altogether then gspeed 1 I think. I dont suggest it
2007-07-14, 05:06
Member
6 posts

Registered:
Mar 2007
Fix oztf!

PS Cheers.
2007-10-04, 19:04
Member
159 posts

Registered:
Jun 2007
vegetous

just wondering if theres been any progress on this project?
FortressOne - A QuakeWorld Team Fortress package for Windows and Linux | https://www.fortressone.org
2007-10-14, 03:31
Member
785 posts

Registered:
Mar 2006
Sorry but I'm not working on the code. I just made some changes for the brazilian TF community!

btw.: gspeed of 1.76 is not working properly (TF players reported that 1.45 worked fine).
https://mega.nz/#F!pZZnBLCK!fZxeV9Lwa76-CG5mdKlbVA - QuakeFiles
  49 posts on 2 pages  First page12Last page