User panel stuff on forum
  4 posts on 1 page  1
Client Talk
2018-04-06, 22:52
Member
41 posts

Registered:
Apr 2017
Hi!,
I've just added a new server list to server browser's sources and it all worked fine. And as expected a sources.txt file with a reference to my serverlist was also saved to ezquake/sb folder. Easy!!... But wait... when I restarted EzQuake my server list doesn't shows up in browser sources. It seems as though it's simply not loading the sources.txt file and is instead using an internal list.

Is this a known issue?. Or am I just crap at this?
2018-04-07, 09:37
Member
41 posts

Registered:
Apr 2017
Okay, I figured it out. The sources.txt in ezquake.pk3 was being used.
2018-04-07, 17:58
Member
182 posts

Registered:
Feb 2011
Wasn't there a change made to ezquake at some point so that it would give higher priority to files outside of pk3s? I know there was a discussion specifically around hud files, maybe .txt files weren't addressed. In any case, I like nquake and use it but putting everything inside pk3 files seems to cause many problems and confusion when someone tries to modify anything...
2018-04-08, 08:10
Administrator
244 posts

Registered:
Sep 2015
BLooD_DoG wrote:
Wasn't there a change made to ezquake at some point so that it would give higher priority to files outside of pk3s? I know there was a discussion specifically around hud files, maybe .txt files weren't addressed.


I think you're referring to changes made for Quakecon... the search rules for a specific file weren't changed as such, but when searching for an image it searches for multiple extensions (.png .tga .jpg etc) and old ezQuake used to prioritise by type. We changed it because it meant people couldn't over-ride nquake files without looking into .pk3 and the converted to the same extension/type, which wasn't intended.

I'm a bit more surprised that sb/sources.txt is an issue, maybe it is being saved to the wrong place?
  4 posts on 1 page  1