User panel stuff on forum
  7 posts on 1 page  1
Client Talk
2017-09-14, 18:38
Member
338 posts

Registered:
Feb 2006
I get a message about this when trying to connect to for example dev.badplace.eu servers

Could somebody remove that check ?

Your client lacks the necessary extensions to ocnnect to this server set /cl_pext_floatcoords 1, or upgrade to ezquake 2.2 etc.

I'm on Ezquake 3.x on MAC OSX, and do not have that command
ProjectQ1Q3, Frogbot Waypoint and Map Conversion Tutorial @ http://mickkn.mooo.com
2017-09-14, 19:24
Administrator
279 posts

Registered:
Sep 2015
Mick wrote:
I'm on Ezquake 3.x on MAC OSX, and do not have that command


Can you do /version and report which exact version you're on?

Having a look at the code there are #ifdefs around the cvar but they should all be enabled, so that command should be there. The option has been enabled on those servers since March, as ezquake 2.2 upwards has support. The only remaining difficulty is that it blocks Qizmo users from connecting.
2017-09-15, 18:55
Member
338 posts

Registered:
Feb 2006
Okay. I was on 2.1 for some reason

But I can't seem to find 2.2 for Mac anywhere and

3.0.0 and 3.0.1 gives me this error

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/libSDL2-2.0.0.dylib
Referenced from: /Users/USER/*/EZQuake-GL2.1 kopi.app/Contents/MacOS/EZQuake-GL
Reason: Incompatible library version: EZQuake-GL requires version 5.0.0 or later, but libSDL2-2.0.0.dylib provides version 3.0.0
ProjectQ1Q3, Frogbot Waypoint and Map Conversion Tutorial @ http://mickkn.mooo.com
2017-09-15, 19:16
Administrator
279 posts

Registered:
Sep 2015
Can you try the ezquake releases page?

We had some trouble with compiling for different versions of OSX... you can try the 3.0 'full', then replace the executable in the page with 3.0.1 upgrade or 3.0 upgrade for "xcode 6.2".

As you can see my understanding of OSX is 1/10...
2017-09-16, 08:34
Member
338 posts

Registered:
Feb 2006
Okay. 3.0.1 actually works on my machine

I just don't like the way it's made because you need to add files to the ezquake.app package

2.1 has the .app file search for ezquake and qw dir in the same folder where the .app file is, just like .exe on windows.

I did a fix to move the ezquake-darwin-x86_64 excutable to the Quakeworld folder and execute it from the terminal, but now I get that error about the Framework file
ProjectQ1Q3, Frogbot Waypoint and Map Conversion Tutorial @ http://mickkn.mooo.com
2017-09-16, 19:49
Member
338 posts

Registered:
Feb 2006
Okay....

Fixed it after brew doctor and fixing all the symbolic links to libraries
ProjectQ1Q3, Frogbot Waypoint and Map Conversion Tutorial @ http://mickkn.mooo.com
2017-09-16, 20:47
Member
338 posts

Registered:
Feb 2006
Argh


bla bla
../Games/Quakeworld/ezquake-darwin-x86_64.command ; exit;
Error: Couldn't load gfx/palette.lmp
logout


This happends when I try to run it from finder and not from Terminal heeeelp I don't want to enter terminal each time
ProjectQ1Q3, Frogbot Waypoint and Map Conversion Tutorial @ http://mickkn.mooo.com
  7 posts on 1 page  1