User panel stuff on forum
  6 posts on 1 page  1
Client Talk
2015-12-10, 18:30
Member
29 posts

Registered:
Sep 2013
Hi Guys,

Anyone else having issues to run our beloved game under Windows10? I cannot make it working so far.
It completely freezes the PC when I run it as normal user. Also when I run it with "Run as administrator"
Administrator (different user account) can run it.

I tried to compatibility mode without success.
I tried the 2.1.1 exe (from 2011-12-08), and the 3.0 exe (from 2015-06-17).

Other openGL/directX based games are running, so this has to do something with ezQuake, I think.

Please help!


Thanks and regards,
Toma
2015-12-11, 10:02
Administrator
263 posts

Registered:
Sep 2015
toma wrote:
Anyone else having issues to run our beloved game under Windows10?


When you say it's hanging, do you mean it just doesn't launch (no menu, program just doesn't appear on screen?) or it starts to run but then hangs on the menu, when you're playing etc?

If it just doesn't appear on screen, how long do you leave it for? You could try running it with -condebug and see if it produces a qconsole.log file in the qw directory, this might give an idea of where it's stuck at. I have Windows 10 and everything is fine now, but I had problems when I first upgraded, with Quake & other things (playing videos in a browser for instance) appearing to hang or crash - now I have "Disable Sound Blaster enhancements" box ticked in the speaker properties, and everything has been fine since.

Sorry that's probably not much help, but if nothing else changed then I suspect drivers are probably the issue. Have you tried other qw clients, to see if they have the same problem?
2015-12-13, 15:10
Member
26 posts

Registered:
Apr 2012
toma wrote:

Anyone else having issues to run our beloved game under Windows10?


Yes me.
I can start and play, but when I quit, everything freezes, can''t do anything other then hard reset the PC.

I then tried fodQuake, no problems yet, I play tested, then quit, no freeze.

When I just start ezquake, then do nothing (i.e. not join a server and play, then quit, then no freeze.
Also when I view a demo, and after it quit, = freeze.

- QuakeR
2015-12-13, 19:25
News Writer
220 posts

Registered:
Jan 2013
Dunno if this is the problem, but anyway: You need to disable some Xbox thing that's default in Win10. Also, preventing Windows Update from auto-updating and auto-checking for updates is supposed to be a pain in the ass. I went back to Win7. More here:
https://www.reddit.com/r/DotA2/comments/3emycw/for_all_you_updating_to_windows_10_this_is_how_to/
http://www.redmondpie.com/disable-turn-off-automatic-updates-in-windows-10-heres-how/
2015-12-20, 14:12
Administrator
104 posts

Registered:
Sep 2013
Hi Guys. I had similar issues on Win7 64bit with 2.2 version. After playing a while and quitting, ezq choose to stay in processes list. Main window disappeared leaving zombie process behind. Tried different methods to get rid of it but all failed. I couldn't also launch new instance of Quake as the old one was still there. Reboot 'solved' the issue (sic!) at that time.

My permanent solution was to upgrade ezq binary to 'some' other revision (trial and error).

Recently I have upgraded ezq to ezquake-e3707f1.exe build (version 3.0 in general) and it worked on WIn7 64bit as well. Having that in mind I also tested on Win10 64bit (fully patched, recent build) and it still works pretty well. No issues at all.
play.quake1.pl
2015-12-30, 20:53
Member
26 posts

Registered:
Apr 2012

No more freezes for me on win10 since using ezQuake 3.0 Nightlybuild 1cde329

- QuakeR
  6 posts on 1 page  1