User panel stuff on forum
  7 posts on 1 page  1
Help
2015-09-04, 01:49
Member
11 posts

Registered:
Aug 2014
Hi guys.

I want to play Quake again (I used to play 1996-2002), but now the only computer I have is Macbook Pro laptop (retina, mid-2014) and I suffer with both Ezquake and Fodquake, the whole thing is not quite playable right now, it feels very slow and laggy.

1) My fps is limited to 60 (it's display's refresh rate I guess, cl_maxfps is 0). Is there a chance to fix it by any commands?

2) I just bought Logitech g500 and I don't know if it's working properly in the game, I've never had that kind of mouse. Are there any commands to check if it works as it should?

Thank you!
2015-09-04, 09:40
Member
148 posts

Registered:
Sep 2013
robotector wrote:
Macbook Pro laptop (retina, mid-2014)


Wow, playing on a Retina laptop!

I got much better performance on my MacBook Air after compiling ezQuake 3 myself (no bundle is available that I know of):
https://github.com/ezQuake/ezquake-source

There are compiling tips in the COMPILING_ON_OSX.txt file:
https://github.com/ezQuake/ezquake-source/blob/master/COMPILING_ON_OSX.txt

Be aware, trunk had serious issues for me, so I live further back (d223ec5a). I had commented at the time:
https://github.com/ezQuake/ezquake-source/commit/96a29e8829c170c200945b3d264f73d8236ff5f5#commitcomment-9642423

--

(1) Try checking other fps commands? cl_physfps? How are you measuring the fps? My MacBook Air shows 400+ with `hud_fps_show 1`.
(2) Should work fine with any mouse. I used a Logitech G400s without issues.

Good luck!
2015-09-04, 09:53
Member
459 posts

Registered:
Mar 2008
robotector wrote:
Hi guys.

I want to play Quake again (I used to play 1996-2002), but now the only computer I have is Macbook Pro laptop (retina, mid-2014) and I suffer with both Ezquake and Fodquake, the whole thing is not quite playable right now, it feels very slow and laggy.

1) My fps is limited to 60 (it's display's refresh rate I guess, cl_maxfps is 0). Is there a chance to fix it by any commands?

2) I just bought Logitech g500 and I don't know if it's working properly in the game, I've never had that kind of mouse. Are there any commands to check if it works as it should?

Thank you!


I'm not familiar with Mac, but it looks to me like you got v_sync enabled. It's usually some setting you can disable in the Graphics Adapter settings. (nVidia control panel for nvidia cards).

Also disabling mouse acceleration and using "in_mouse 3" is in general a good idea.

Other commands you could try:

cl_physfps 77
cl_maxfps 308
2015-09-04, 15:41
Member
11 posts

Registered:
Aug 2014
BogoJoker wrote:
robotector wrote:
Macbook Pro laptop (retina, mid-2014)


Wow, playing on a Retina laptop!

I got much better performance on my MacBook Air after compiling ezQuake 3 myself (no bundle is available that I know of):
https://github.com/ezQuake/ezquake-source

There are compiling tips in the COMPILING_ON_OSX.txt file:
https://github.com/ezQuake/ezquake-source/blob/master/COMPILING_ON_OSX.txt

Be aware, trunk had serious issues for me, so I live further back (d223ec5a). I had commented at the time:
https://github.com/ezQuake/ezquake-source/commit/96a29e8829c170c200945b3d264f73d8236ff5f5#commitcomment-9642423

--

(1) Try checking other fps commands? cl_physfps? How are you measuring the fps? My MacBook Air shows 400+ with `hud_fps_show 1`.
(2) Should work fine with any mouse. I used a Logitech G400s without issues.

Good luck!


Thank you for your answer!

I tried to compile it from this particular commit, and this is what I get: https://gist.github.com/macovsky/4b665afc147a058bb985.

1) I tried cl_physfps but it itself doesn't change anything. I just used hud_fps_show like you do.

2) Did you use smoothmouse or something? Or EZQ tries to read raw input?

(Edited 2015-09-04, 16:15)
2015-09-04, 16:11
Member
11 posts

Registered:
Aug 2014
Rikoll wrote:
robotector wrote:
Hi guys.

I want to play Quake again (I used to play 1996-2002), but now the only computer I have is Macbook Pro laptop (retina, mid-2014) and I suffer with both Ezquake and Fodquake, the whole thing is not quite playable right now, it feels very slow and laggy.

1) My fps is limited to 60 (it's display's refresh rate I guess, cl_maxfps is 0). Is there a chance to fix it by any commands?

2) I just bought Logitech g500 and I don't know if it's working properly in the game, I've never had that kind of mouse. Are there any commands to check if it works as it should?

Thank you!


I'm not familiar with Mac, but it looks to me like you got v_sync enabled. It's usually some setting you can disable in the Graphics Adapter settings. (nVidia control panel for nvidia cards).

Also disabling mouse acceleration and using "in_mouse 3" is in general a good idea.

Other commands you could try:

cl_physfps 77
cl_maxfps 308


Oh wow, that was v_sync indeed, I managed to turn it off with in a very awkward way http://stackoverflow.com/questions/12345730/how-to-disable-vsync-on-mac-osx and now I get 308 fps! Thank you.

BTW what is that timerefresh command? How come it shows 3000 fps? Is it real?

Unfortunately there's no in_mouse for mac versions I guess. How do you usually ensure that mouse is actually working as expected? Just by your experienced feel?
2015-09-04, 17:44
Member
148 posts

Registered:
Sep 2013
Oh, I forgot. I had installed SmoothMouse on my Mac for games. Hopefully that helps a little bit!
http://smoothmouse.com
2015-09-13, 10:52
Member
322 posts

Registered:
Nov 2006
1. To disable vertical sync in Fodquake on OS X just use "vid_vsync 0". No requirement for 3rd party tools or hacks.

2. Mouse in Fodquake on OS X directly reads information from the USB bus. I think this is the most raw info you can get. This also means 3rd party applications probably won't have any impact on the smoothness, acceleration curves etc pp. That is also the reason why the mouse won't work when you install Razer drivers.



3. The ezquake compile issue is because you are using not the latest version. You will need to make this change for a successful compile:

https://github.com/ezQuake/ezquake-source/commit/e76e7ce885f5653f4815106e91cee59ef6468761
  7 posts on 1 page  1