User panel stuff on forum
  15 posts on 1 page  1
Client Talk
2011-10-30, 19:17
Member
1 post

Registered:
Oct 2011
I recently installed ezQuake (using nQuake installer) on my Mac.
When I try to launch ezQuake this error is popped
Process: EZQuake-GL [30459]
Path: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
Identifier: net.sf.ezquakegl
Version: 1517 (1.1)
Code Type: X86 (Native)
Parent Process: launchd [235]

Date/Time: 2011-10-30 20:34:08.162 +0200
OS Version: Mac OS X 10.7.2 (11C74)
Report Version: 9

Interval Since Last Report: 74848 sec
Crashes Since Last Report: 11
Per-App Crashes Since Last Report: 4
Anonymous UUID: 24A15638-A062-4E45-A9CB-E120724684CF

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/Growl.framework/Versions/A/Growl
Referenced from: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
Reason: image not found

Binary Images:
0x1000 - 0x319ff7 +net.sf.ezquakegl (1517 - 1.1) <1E8C2BEC-03B3-7695-518B-4DACC3CCFC2E> /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
0x8feeb000 - 0x8ff1d9c7 dyld (195.5 - ???) <134323A7-49DC-3A9D-ACFD-32FAD0FD6BA2> /usr/lib/dyld
0x90abb000 - 0x90b1cffb com.apple.audio.CoreAudio (4.0.1 - 4.0.1) <089D78E0-46A6-38DB-9545-7F35CC815939> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x91dcd000 - 0x91e31fff com.apple.framework.IOKit (2.0 - ???) <D14460ED-2B6C-375D-B3A4-B8C82E922666> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x95c5b000 - 0x95c69fff com.apple.opengl (1.7.5 - 1.7.5) <81166D23-DE8E-3938-AAD3-29B1FA5E446E> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x95cf1000 - 0x95f76fe3 com.apple.QuickTime (7.7.1 - 2306) <F8C64DC4-3FE4-3A06-B10B-59E7F3BA6FDD> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime
0x96ddb000 - 0x96ddbff0 com.apple.ApplicationServices (41 - 41) <BED33E1D-C95C-3654-9A3A-0CB3607F9F10> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x96fc0000 - 0x96fd8ff7 libexpat.1.dylib (7.2.0 - compatibility 7.0.0) <C7003CC0-28CA-3E04-9B9E-0A15138ED726> /usr/lib/libexpat.1.dylib
0x9b2b1000 - 0x9b2bffff libz.1.dylib (1.2.5 - compatibility 1.0.0) <E73A4025-835C-3F73-9853-B08606E892DB> /usr/lib/libz.1.dylib
0x9bb0e000 - 0x9bb0efff com.apple.Cocoa (6.6 - ???) <650273EF-1ABC-334E-B745-B75AF028F9F4> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

Model: MacBookPro5,2, BootROM MBP52.008E.B05, 2 processors, Intel Core 2 Duo, 2.66 GHz, 4 GB, SMC 1.42f4
Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533641465238432D47372020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533641465238432D47372020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.100.98.75.18)
Bluetooth: Version 4.0.1f4, 2 service, 11 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: FUJITSU MHZ2320BH FFS G1, 320.07 GB
Serial ATA Device: MATSHITADVD-R UJ-868
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x04600000 / 3
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 2
USB Device: Razer Imperator, 0x1532, 0x0017, 0x06400000 / 3
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000 / 2
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8217, 0x06110000 / 5



What I noticed to be very strange is this line:
Library not loaded: @executable_path/../Frameworks/Growl.framework/Versions/A/Growl

I have Growl 1.3 working with any other growl-supported application.

Why a game client such as ezQuake makes use of the growl framework?
2011-10-30, 20:25
Administrator
1023 posts

Registered:
Apr 2006
Growl surely aint needed, most of it is commented out. I'm guessing it was some old stub from someone starting a project to implement or something.

I'm guessing we can just comment out the growl part in the code and ask Tuna or someone to build a new binary.
2011-10-31, 06:33
Member
2 posts

Registered:
Oct 2011
Hey, I was just about to made a comment about the same problem though I run Mac OS X 10.6.8, Snow Leopard that is.
2011-10-31, 11:02
Administrator
1023 posts

Registered:
Apr 2006
I could comment it out, but I can't build a new binary unfortunately.

Anyone of you have the possibility to build an executable for Mac OSX, then I can fix the code and let you try it?
2011-11-08, 19:51
Member
12 posts

Registered:
Jul 2009
I'm getting the same issue, posting my crash report in case it might help.

Process: EZQuake-GL [6386]
Path: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
Identifier: net.sf.ezquakegl
Version: 1517 (1.1)
Code Type: X86 (Native)
Parent Process: launchd [128]

Date/Time: 2011-11-08 20:30:43.594 +0100
OS Version: Mac OS X 10.7.2 (11C74)
Report Version: 9

Interval Since Last Report: 1486644 sec
Crashes Since Last Report: 11
Per-App Crashes Since Last Report: 3
Anonymous UUID: F98FB7C2-4195-430C-868B-32CF623ADC05

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/Growl.framework/Versions/A/Growl
Referenced from: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
Reason: image not found

Binary Images:
0x1000 - 0x319ff7 +net.sf.ezquakegl (1517 - 1.1) <1E8C2BEC-03B3-7695-518B-4DACC3CCFC2E> /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
0x8fedb000 - 0x8ff0d9c7 dyld (195.5 - ???) <134323A7-49DC-3A9D-ACFD-32FAD0FD6BA2> /usr/lib/dyld
0x92926000 - 0x92934fff libz.1.dylib (1.2.5 - compatibility 1.0.0) <E73A4025-835C-3F73-9853-B08606E892DB> /usr/lib/libz.1.dylib
0x945f7000 - 0x9460fff7 libexpat.1.dylib (7.2.0 - compatibility 7.0.0) <C7003CC0-28CA-3E04-9B9E-0A15138ED726> /usr/lib/libexpat.1.dylib
0x94610000 - 0x94610ff0 com.apple.ApplicationServices (41 - 41) <BED33E1D-C95C-3654-9A3A-0CB3607F9F10> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x955db000 - 0x95860fe3 com.apple.QuickTime (7.7.1 - 2306) <F8C64DC4-3FE4-3A06-B10B-59E7F3BA6FDD> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime
0x96673000 - 0x96681fff com.apple.opengl (1.7.5 - 1.7.5) <81166D23-DE8E-3938-AAD3-29B1FA5E446E> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x976da000 - 0x9773bffb com.apple.audio.CoreAudio (4.0.1 - 4.0.1) <089D78E0-46A6-38DB-9545-7F35CC815939> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x99055000 - 0x99055fff com.apple.Cocoa (6.6 - ???) <650273EF-1ABC-334E-B745-B75AF028F9F4> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x99076000 - 0x990dafff com.apple.framework.IOKit (2.0 - ???) <D14460ED-2B6C-375D-B3A4-B8C82E922666> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

Model: MacBookPro5,5, BootROM MBP55.00AC.B03, 2 processors, Intel Core 2 Duo, 2.53 GHz, 4 GB, SMC 1.47f2
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x802C, 0x31364A53463235363634485A2D3147314631
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x802C, 0x31364A53463235363634485A2D3147314631
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.100.98.75.18)
Bluetooth: Version 4.0.1f4, 2 service, 11 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: FUJITSU MJA2250BH FFS G1, 250,06 GB
Serial ATA Device: MATSHITADVD-R UJ-868
USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0x24100000 / 3
USB Device: Apple Keyboard, apple_vendor_id, 0x0221, 0x24120000 / 4
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26500000 / 2
USB Device: Razer Abyssus, 0x1532, 0x001c, 0x06200000 / 3
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000 / 2
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06110000 / 5
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0237, 0x04600000 / 3
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 2
2011-11-08, 19:52
Member
40 posts

Registered:
Feb 2009
Have you tried w/o your cfg file? For me it works perfectly (10.4, 10.5, 10.6, 10.7).
/say_team $R fuck yeah!
2011-11-08, 20:32
Member
323 posts

Registered:
Nov 2006
It probably works when you have a corresponding installation of the Growl framework on your machine. There might be 32 bit / 64 bit mismatches. Since ezQuake is 32 bit it also needs 32 bit Growl framework I suppose..
2011-11-16, 17:02
Member
1 post

Registered:
Oct 2006
third party softwares :|

(Edited 2017-10-09, 06:47)
2011-11-17, 08:43
Administrator
1023 posts

Registered:
Apr 2006
Tuna wrote:
It probably works when you have a corresponding installation of the Growl framework on your machine. There might be 32 bit / 64 bit mismatches. Since ezQuake is 32 bit it also needs 32 bit Growl framework I suppose..

Afaik, there's only stubs left in the code (like a couple of lines) and the rest which looks like the beginning of an implementation is #if 0:ed out, so how about we remove it instead to get rid of this annoying problem?

Feel free to correct me if I'm wrong, I can't test since I don't have access to a Mac yet
2011-11-17, 10:05
Member
323 posts

Registered:
Nov 2006
Sure remove it. Critical thing is also to remove linking to the library or nothing is gained. Not sure if i can make a compile easily. My XCode setup is somewhat messed up atm.. Is there a planned maintenance release ahead?
2012-02-28, 15:33
Member
2 posts

Registered:
Oct 2011
Is someone going to fix the mac build? I dunno how to get to work myself and I get same crash log as before.
2012-04-20, 22:11
Member
1011 posts

Registered:
Feb 2006
did anyone ever sort this out or is it still needed?
2012-04-20, 23:08
Member
1011 posts

Registered:
Feb 2006
try http://dl.dropbox.com/u/951543/EZQuake-GL.zip
2012-05-01, 06:38
Member
323 posts

Registered:
Nov 2006
It's definately time to provide a OSX 2.1.1 version as there exists one for windows. Can you check this with Johnny and eventually package your version? :-)
2012-06-18, 00:11
Member
76 posts

Registered:
Oct 2009
10.6.8
installed nquake - crash as above, installed Growl, no go.

then I updated ezquake http://sourceforge.net/projects/ezquake/files/stable/2.1/ezquake_mac_2.1.zip/download - downlaoded file, unopacked, drag & drop to /Applications/nQuake and clicked Replace.
Had to add -mem 256 in CLI otherwise it would crash doe to not enoug memory
  15 posts on 1 page  1