User panel stuff on forum
  9 posts on 1 page  1
Help
2009-08-20, 16:34
Member
50 posts

Registered:
Jul 2009
Recently i have been wanting to switch to nix, for numerious reasons, But there is one thing holding me back.... No matter what i do, I cannot get quake to run even 1/4 as smooth as it does on windows (even running same hz/fps/config/everything). I'm wondering if anyone else has had these problems and somehow fixed it, making qw run as smooth on nix as it would on win. I'm starting to think I have not configured my drivers properly or some issue like this, but I simply to not have the knowledge with driver-settings on linux.

edit: I have read the "Smooth qw in linux" guide and followed that also, still no luck

tia, Jack
2009-08-20, 20:19
Member
1099 posts

Registered:
Jan 2006
What do you mean by "smooth"?
What's your hardward, distro, drivers, engine, (major) settings?
2009-08-20, 22:54
Member
4 posts

Registered:
Aug 2009
Did you increase the mouse polling rate? As root, do

$ echo 2 > /sys/bus/usb/drivers/usbhid/module/parameters/mousepoll

for that will raise your polling rate to 500Hz. ("2" is the polling interval in milliseconds). Note: These settings will be lost after reboot.
2009-08-20, 23:32
Member
50 posts

Registered:
Jul 2009
Spirit,

E6600@2.4ghz/8800/4GB OCZ, ubuntu 9.04, latest hardware drivers on ubuntu, engine?(gl if you mean that or sw), 144hz/800x600/308.0fps constant
2009-08-21, 05:30
Member
64 posts

Registered:
Jan 2009
A longshot but may be related to /cl_nolerp.
I used an old config from fuhquake when I started playing again and that old "fuhqw-config" ran smooth in windows, but not in linux.

The only thing that made a bid difference that I remember was the nolerp.

Tip: try other configs (by cfg_load) and then if some config gets you the experience you want - you atleast know it's the cfg settings and not some OS parameter.
2009-08-21, 07:47
Member
1433 posts

Registered:
Jan 2006
Spirit wrote:
What do you mean by "smooth"?

I have to repeat the question here.
People have various definitions for "unsmooth".
- unstable fps (ok, you said that's not the case)
- lagged mouse input
- lagged keyboard input
- delayed video
- delayed sound
- small periodic freezes
- other sort of FPS/CPU spikes
- something else
2009-08-21, 12:56
Member
50 posts

Registered:
Jul 2009
Conus, thanks i shall try that

Spirit/Johnny, Its hard to explain, it feels as if im using 60hz or something, feels like low fps, yet i get 308 constant and my monitor runs @ 100hz
2009-08-21, 16:21
Member
37 posts

Registered:
Jan 2008
Disable all the fancy eye-candy 3D stuff that Ubuntu has... I play on some old release of Ubuntu and it is extremely smooth but that was before they lumped in all the compiz/xgl, don't know what there is now. You could try a different display manager just to test... are you using Gnome?
2009-08-21, 17:13
Member
26 posts

Registered:
Jul 2007
I had similar issues. For me it helps to run quake in another session (xinit /path/to/qwcl -- :1). I believe this is common for Ubuntu users.
  9 posts on 1 page  1