User panel stuff on forum
  31 posts on 2 pages  First page12Last page
Client Talk
2008-04-29, 08:30
Member
129 posts

Registered:
Mar 2007
I installed Ubuntu 8 (possibly 64bit version but I can't remember which I downloaded) last night. I tried to install and run ezQuake 1.9 and it complained that it couldn't find libXxf86dga.so.1.

I verified that the package was installed and that the file was present in /usr/lib. I installed the libXxf86dga-dev package just for fun - no good. I created a symlink to my quake directory to the library and it didn't fix the problem. I then downloaded ezQuake 1.8.3 and it ran straight away (sound is lagged but I'll be able to fix that myself).

Has something changed between versions - or am I dense. Note that these are not mutually exclusive.
2008-04-29, 09:06
Administrator
1258 posts

Registered:
Jan 2006
hai mate

can't answer your question, but I got the same sound problem. im such a noob, cant fix it. maybe u can post on http://wiki.qwdrama.com/Smooth_Quake_in_Linux explaining what to do?

love
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2008-04-29, 10:50
Member
715 posts

Registered:
May 2006
driz, there's a tool for you that can scan binaries and download libraries automatically:
getlibs ezquake-gl.glx
---Where can you see lions? Only in kenya! Come to kenya we've got lions.
2008-04-29, 11:39
Member
129 posts

Registered:
Mar 2007
cheers molgrum, I'll give that a crack tonight.

mushi: I think there's a thread here detailing a range of possible solutions to the lagged sound issue. I'm planning on following one of those steps, or becoming awesome at C and sticking FTE's sound code into ezquake. The first option is more likely.

well i'd rather port darkplaces soundengine
2008-04-29, 11:45
Member
715 posts

Registered:
May 2006
Or you can use FTE
---Where can you see lions? Only in kenya! Come to kenya we've got lions.
2008-04-29, 12:36
Member
129 posts

Registered:
Mar 2007
Yeah I should give that a crack too.
2008-04-29, 12:37
Member
1100 posts

Registered:
Jan 2006
That is weird. It works fine here.
Try running ldconfig as root, maybe that helps.
If it does not help please post the output of ls -l /usr/lib/libXxf86dga*
2008-04-29, 17:41
Member
129 posts

Registered:
Mar 2007
Confirmed as running ubuntu 64bit. Think I might grab the 32bit version since I have no need for 64bit. No need to complicate things.

Anyway, this is the output from ls -l /usr/lib/libXxf86dga*

-rw-r--r-- 1 root root 28836 2007-11-01 04:11 /usr/lib/libXxf86dga.a
lrwxrwxrwx 1 root root 20 2008-04-28 22:47 /usr/lib/libXxf86dga.so -> libXxf86dga.so.1.0.0
lrwxrwxrwx 1 root root 20 2008-04-28 22:48 /usr/lib/libXxf86dga.so.1 -> libXxf86dga.so.1.0.0
-rw-r--r-- 1 root root 24416 2007-11-01 04:11 /usr/lib/libXxf86dga.so.1.0.0

Tried fte btw, it claims that ALSA isn't compatible or nonexistent and attempts to use OSS, which fails with a broken pipe.
2008-04-29, 19:19
Member
27 posts

Registered:
Feb 2006
Anyone else having trouble with the evdev support with ubuntu8?
It has always worked fine before but when I turn on mmt now the mouse won't work and without mmt it feels like shit.
I have the correct settings I think in_mouse to 3 and in_evdevice to /dev/input/event2.
2008-04-29, 19:22
Member
271 posts

Registered:
Feb 2006
driz wrote:
Confirmed as running ubuntu 64bit. Think I might grab the 32bit version since I have no need for 64bit. No need to complicate things.

Tried fte btw, it claims that ALSA isn't compatible or nonexistent and attempts to use OSS, which fails with a broken pipe.

Firstly the ezquake issue. If you're using a 32bit version of ezquake on a 64bit linux, chances are that ezquake isn't loading because it can't find the 32bit version of the dga library (I had the same issue on my computer, note that 32bit libs on a 64bit system will be in /usr/lib32 or somewhere like that, so look for the libs in that directory instead).

Secondly the FTE issue. Its probably accurate. ALSA sucks.
Its generating that message because it couldn't find libasound.so when it tried dynamically linking to it.
You can probably fix it with a symlink. Chances are you have a compatible libasound.so.1 or something in your libs directory, just link libasound.so to that.
Might just be that you can install the dev library for your distribution.
OSS4 will probably give you better sound latency though, of course.
moo
2008-04-29, 21:32
Member
129 posts

Registered:
Mar 2007
I installed 32bit ubuntu before reading this post and it worked without issue. I may install the x64 just to try fixing it for fun. Will have to look in lib32.

FTE sound worked after installing libasound2-dev package - cheers! FTE is now running more or less perfectly.

Will have to set it all up properly after the NQR final though, don't wanna change stuff midway through.
2008-04-29, 22:19
Member
715 posts

Registered:
May 2006
Updated FTE to look for alternative libasound filenames to fix this issue. The next nightly build will contain the update if you should need it: http://users.tpg.com.au/users/moodles/

If you have any questions/problems feel free to tell us @ #fte
---Where can you see lions? Only in kenya! Come to kenya we've got lions.
2008-05-07, 15:03
Member
7 posts

Registered:
Sep 2007
I found when i first used ezquake in linux in ubuntu 7.04, it was best to svn the code for ezquake and build it myself because it just didnt play right it seemed to like skip frames or somthing :S ah wells Hope you stay with linux its the way forward tho using 64bit versions... are a bit of a nightmare... i have an amd X2 64 but i still just run the normal i386, tho to be fair 64bit in windows is wayyyyyyyy worse, because at least in linux you can mostly get the code and build the application yourself with the gcc -m64 or somthing i think to build it for the 64bit machine
2008-05-07, 15:27
Member
129 posts

Registered:
Mar 2007
I am planning to stay with Linux if I can get everything working nicely - just waiting till the end of NQR (playing final tonight) before doing anything too drastic. Heading back to mostly QW-less Australia for a few weeks soon so I should have plenty of time to stuff around with it.

WoW + wine works out of the box with ubuntu 8.04 which was nice
2008-09-05, 22:34
Member
51 posts

Registered:
Apr 2007
Sry that i just dig out this thread and ask such a noob question, but: how to start those .glx files?

i just started with linux (Linux Mint which is based on Ubuntu 8.04) today but i cant get ezquake to work anyway (used windows for years :S)...

is there a total beginner guide anywhere so i can play qw while staying with Linux?

i thank anyone, who could help me out :S

oRe
2008-09-05, 23:10
Member
24 posts

Registered:
May 2008
right click on the .glx file then run in terminal.
2008-09-08, 18:27
Member
51 posts

Registered:
Apr 2007
OldTattoo wrote:
right click on the .glx file then run in terminal.

thank you for the first starting help...

but now i've got the next question :S

How to start it in fullscreen? i searched the web up and down for it (maybe wrong keywords dunno...) not finding an answer :S

and btw. ingame "fullscreen" option doesnt work the way it should =/

i must be the dumbest linux user ever oO

ty in advance

oRe
2008-09-09, 08:57
Member
1100 posts

Registered:
Jan 2006
How does the ingame fullscreen setting not work correctly? It will only apply once you select "Apply Settings". Or does it really not work for you?
2008-09-09, 13:53
Member
51 posts

Registered:
Apr 2007
i tried it with "Apply Settings" before i asked here...

but it does not work either...

:S

could it be that it has something to do with the config i used in windows too?
2008-09-09, 14:37
Member
24 posts

Registered:
May 2008
maybe , i have tried to use the same cfg file from my windows box , does not seem to work , think it maybe someting todo with the video settings try removing the config.cfg file and restart exquake it should write a new one .
2008-09-09, 14:51
Member
51 posts

Registered:
Apr 2007
OldTattoo wrote:
maybe , i have tried to use the same cfg file from my windows box , does not seem to work , think it maybe someting todo with the video settings try removing the config.cfg file and restart exquake it should write a new one .

hmm same result with "new" config :S

so i think that it's not the cfg =/
2008-09-09, 15:31
Member
705 posts

Registered:
Feb 2006
i think you need to have the fullscreen resolution set in xorg.conf or similar
2008-09-09, 16:13
Member
1100 posts

Registered:
Jan 2006
Ah yes, you won't be able to use a different resolution from the ones in your system's configuration (maybe with some indepth trouble).
2008-09-09, 19:03
Member
51 posts

Registered:
Apr 2007
that might be the fault...

is there any good manual for configuring the xorg.conf? (with most options etc., i would like to configure it completely, when i start doing it)

i read some pages about configuring the xorg.conf including tuning the mouse to 1000hz (or 500 :S), but non showing most things/everything that could be done...

okay just found out about "man xorg.conf" or is there any better? :S
2008-09-09, 22:15
Member
705 posts

Registered:
Feb 2006
wiki.qwdrama.com/Smooth_Quake linux section for tweaking mouse
2008-09-19, 15:59
Member
51 posts

Registered:
Apr 2007
the next problem i came over: right now i got everything to work right... but something i just recognised:

with in_mouse "2" / in_evdevice "/dev/input/event2" (event2 is my razer db 3g), mouse works, but have a horrible "Lag" sometimes when it comes to using weapons as accurate as possible... i cant get it to point on special "pixels" but in a lucky moment, which wasnt like that back in windows...

with in_mouse "3" / same in_evdevice, it won't even work...

for my razer i use evdev driver in xorg.conf... so in_mouse "3" should work, i think :S

well another thing, not really related to ezQ is that my db 3g polled at 1000hz in windows and now in Linux Mint with just 500hz :S

edit: no answer so far, but that's no problem...

but my problem is present as before =/

i just got some new information about the problem:

when i did an in_restart it told me ezQ couldn't read event2, knowing that i chmod'ed my event2 to 644 so ezQ could read it, but then the next error appeared telling me "evdev error: during thread cancel" which i couldn't get around since then =/ maybe anyone of you can help me to get in_mouse 3 to work as it should :S

and btw it does neither work with in_mmt 0 nor in_mmt 1

sincerely oRe
2008-10-03, 16:20
Member
45 posts

Registered:
Aug 2007
oRe wrote:
the next problem i came over: right now i got everything to work right... but something i just recognised:

with in_mouse "2" / in_evdevice "/dev/input/event2" (event2 is my razer db 3g), mouse works, but have a horrible "Lag" sometimes when it comes to using weapons as accurate as possible... i cant get it to point on special "pixels" but in a lucky moment, which wasnt like that back in windows...

With "in_mouse "2"" your event device doesn't matter, it is irrelevant in this case. You are using the non-DGA X mouse.


Quote:
with in_mouse "3" / same in_evdevice, it won't even work...

Now this is the setting for evdev, right. But did you check that you used the correct event device?


Quote:
but then the next error appeared telling me "evdev error: during thread cancel" which i couldn't get around since then =/ maybe anyone of you can help me to get in_mouse 3 to work as it should :S

and btw it does neither work with in_mmt 0 nor in_mmt 1

That error message "evdev error: during thread cancel" sounds familiar! I get it when trying in_mmt 1, not so with in_mmt 0, though it is recommended (?) to use in_mmt 1. On the other hand, I tried several recent alpha versions of ezquake, and here in_mmt 1 DOES WORK! And I no longer get that error message.


But anyway, I already wrote about similar problems some time ago in this forum. I cannot get used to in_mouse "3", my mouse movement seems unacceptably weird, and my mouse seems to (occasionally) miss a click here and a click there, so my game play sucks when compared to playing in windows XP. I now play with in_mouse "1" (dga mouse), and it feels all right, so much better than with evdev!

There's more to my evdev experience:
I just compiled aprq2 (best quake2 client in my opinion) and compiled in evdev support. I can play with it, but movement is worse than with normal DGA mouse settings. So evdev is not acceptable for me, not in ezquake and not in aprq2. The mouse is so much smoother and less "unstable" with DGA, not that different from Windows XP direct input (which by the way, I also prefer to the new feature of "raw input" in ezquake).

I also gave up ALSA with ezquake (though I could still use the little tricks I once described in order to reduce sound latency), but OSS gives less delay.


sempron
2008-10-03, 21:44
Member
51 posts

Registered:
Apr 2007
sempron wrote:
oRe wrote:
the next problem i came over: right now i got everything to work right... but something i just recognised:

with in_mouse "2" / in_evdevice "/dev/input/event2" (event2 is my razer db 3g), mouse works, but have a horrible "Lag" sometimes when it comes to using weapons as accurate as possible... i cant get it to point on special "pixels" but in a lucky moment, which wasnt like that back in windows...

With "in_mouse "2"" your event device doesn't matter, it is irrelevant in this case. You are using the non-DGA X mouse.


Quote:
with in_mouse "3" / same in_evdevice, it won't even work...

Now this is the setting for evdev, right. But did you check that you used the correct event device?


Quote:
but then the next error appeared telling me "evdev error: during thread cancel" which i couldn't get around since then =/ maybe anyone of you can help me to get in_mouse 3 to work as it should :S

and btw it does neither work with in_mmt 0 nor in_mmt 1

That error message "evdev error: during thread cancel" sounds familiar! I get it when trying in_mmt 1, not so with in_mmt 0, though it is recommended (?) to use in_mmt 1. On the other hand, I tried several recent alpha versions of ezquake, and here in_mmt 1 DOES WORK! And I no longer get that error message.


But anyway, I already wrote about similar problems some time ago in this forum. I cannot get used to in_mouse "3", my mouse movement seems unacceptably weird, and my mouse seems to (occasionally) miss a click here and a click there, so my game play sucks when compared to playing in windows XP. I now play with in_mouse "1" (dga mouse), and it feels all right, so much better than with evdev!

There's more to my evdev experience:
I just compiled aprq2 (best quake2 client in my opinion) and compiled in evdev support. I can play with it, but movement is worse than with normal DGA mouse settings. So evdev is not acceptable for me, not in ezquake and not in aprq2. The mouse is so much smoother and less "unstable" with DGA, not that different from Windows XP direct input (which by the way, I also prefer to the new feature of "raw input" in ezquake).

I also gave up ALSA with ezquake (though I could still use the little tricks I once described in order to reduce sound latency), but OSS gives less delay.


sempron

hmm okay...

in_mouse 1 - when i move the mouse just a little bit, i turn around much to fast to handle
in_mouse 2 - normal mousespeed, but sometimes mouse is not as responsable as it should be (which i mostly recognise on aerowalk, trying to aim through the windows between YA and GL, which is not really possible with this setting)
in_mouse 3 - mouse doesn't even move one pixel...

using a nighlty build and in_mouse 3 removed the error message "evdev error: during thread cancel", but nothing more, so the mouse doesn't work with this either =/

and "ls -al /dev/input/by-id/" gives me the following:

lrwxrwxrwx 1 root root 9 2008-10-03 12:45 usb-Razer_Razer_Diamondback_3G-event-mouse -> ../event2

and "evtest /dev/input/event2" this:

Input driver version is 1.0.0
Input device ID: bus 0x3 vendor 0x1532 product 0xd version 0x110
Input device name: "Razer Razer Diamondback 3G"
Supported events:
Event type 0 (Sync)
Event type 1 (Key)
Event code 272 (LeftBtn)
Event code 273 (RightBtn)
Event code 274 (MiddleBtn)
Event code 275 (SideBtn)
Event code 276 (ExtraBtn)
Event code 277 (ForwardBtn)
Event code 278 (BackBtn)
Event type 2 (Relative)
Event code 0 (X)
Event code 1 (Y)
Event code 8 (Wheel)
Event type 4 (Misc)
Event code 4 (ScanCode)
Testing ... (interrupt to exit)


so i am pretty sure that the event i use is the right :S

thank you for your answer mate

edit: omg <.< i got it to work by doing one of the most easiest things to imagine: replugging the mouse, so it gets a new event number...

now "in_mouse 3" works while using the most recent nightly build oO and it works the way i am used to =)
2008-12-24, 20:49
Member
51 posts

Registered:
Apr 2007
sry, to digg it out again :S

but since I was bored, I changed a running system, updating from linux mint 5 to 6 (ubuntu 8.04 to 8.10) via fresh install, and now again my mouse does not work with "in_mouse 3", everything is configured right, well I think so... (in_evdevice /dev/input/event2 ; where event2 is my normal mouse) and neither in_mmt 1 nor 0 makes it work

i did even try the method, that worked the last time (replugging the mouse to get a new eventnumber), with no effect...

i did try ezQ 1.9, 1.9.2 and the latest nightly (and an older nightly, which I classified "stable" for my purposes) with no effect either...

i hope anyone here can help me, i don't see why it isnt working :S

edit: does it maybe have something to do with Ubuntu 8.10 (and based distributions) use hal instead of the xorg.conf for input devices?
2008-12-25, 03:36
Member
26 posts

Registered:
Feb 2007
Xorg's use your event2, when u in qw, do in_mouse "2" = X mouse = event2 (= 1ms or 2ms usb mouse if u are change mouse.poll to 1 or 2 in kernel module)
i have ubuntu 8.10 too, but i cant change RTC max user freq to 1024, coz its doesnt exist....this is my problem.
anybody?
  31 posts on 2 pages  First page12Last page