User panel stuff on forum
  20 posts on 1 page  1
Client Talk
2006-12-22, 18:11
Member
62 posts

Registered:
Jan 2006
______________________________
Howto install EZQuake (1754) on OSX
Version 1.0
by nopee
2006-12-22
______________________________

WHAT IS THIS?
This Howto will show you how to install EZQuake (Build 1754) on OSX for Macintosh.
EZQuake (Build 1754) is much more difficult to install than previous versions, I had some problems anyhow.
I hope this Howto will help everyone having problems installing EZQuake on OSX.

INSTALLATION

EZQuake (1754)
#1 Download EZQuake "ezquake.sourceforge.net" and install it in you're Quake-dir.

XCODE.
#1 Download and install Xcode "http://developer.apple.com/tools/download/", (It's also avalible on your OSX DVD)

PCRE
#1 Download PCRE "http://mustalainen.se/nopee/QW/OSX/pcre-7.0.tar" and extract it.
#2 cd pcre-7.0.tar.gz
#3 ./configure --prefix=/usr/local CFLAGS=-01
#4 make
#5 sudo make install

EXPAT.
#1 Download EXPAT "http://mustalainen.se/nopee/QW/OSX/expat-2.0.0.tar" and extract it.
#2 cd expat-2.0.0
#3 ./configure --mandir /usr/local/share/man/CFLAGS=-02
#4 make
#5 sudo make install

LIBPNG
#1 Download LIBPNG "http://mustalainen.se/nopee/QW/OSX/libpng-1.2.14.tar" and extract it.
#2 cd libpng-1.2.14
#3 ./configure --prefix=/usr/local
#4 make
#5 sudo make install

GO PLAY!
BEST
NOPEE
2006-12-23, 13:59
Administrator
2058 posts

Registered:
Jan 2006
nice guide!

why do you need xcode, pcre and expat?
2006-12-23, 16:41
Member
62 posts

Registered:
Jan 2006
xcode is for compiling pcre, expat and libpng.

I dont know what the first two packages is for but EZQuake is searching for files from those packages if you dont have them installed.
2006-12-23, 16:53
Member
151 posts

Registered:
Jan 2006
Damn. It seems Oldman make a build with dynamic-linked libraries =:-\
So you have to install all this libraries (pcre=Perl Compitable Regular Expressions, and expat is XML parser) :E
kill me now and burn my soul
2006-12-23, 19:26
Member
62 posts

Registered:
Jan 2006
Disconnect: So i guess those packages shoudnt be required for this build?
Maby I kan skip en for next EZ build then?
2006-12-27, 18:40
Member
1011 posts

Registered:
Feb 2006
disconnect wrote:
Damn. It seems Oldman make a build with dynamic-linked libraries =:-\
So you have to install all this libraries (pcre=Perl Compitable Regular Expressions, and expat is XML parser) :E

they are dynamically linked but included in the .app bundle (that is how you do it on mac) and should be referenced there but there were some problems with the recent release for some reason

on the thread with povohat i told him how to fix it using symbolic links

i'll release a fixed version at some point
2006-12-29, 05:13
Member
37 posts

Registered:
Mar 2006
thanks nopee
2006-12-29, 10:31
Member
341 posts

Registered:
Nov 2006
i have installed the above libraries through macports. with that i was able to see the splash menu. however when i try to click "play" i do get an error. running from the terminal the exact error is:
./EZQuake-GL.app/Contents/MacOS/EZQuake-GL
EZQuake-GL(433,0xa000ed88) malloc: *** vm_allocate(size=3630071808) failed (error code=3)
EZQuake-GL(433,0xa000ed88) malloc: *** error: can't allocate region
EZQuake-GL(433,0xa000ed88) malloc: *** set a breakpoint in szone_error to debug
2006-12-29 11:25:17.544 EZQuake-GL[433] An error has occured: Q_malloc: Not enough memory free; check disk space

any ideas what may be wrong? the allocation size seems a bit high?
2006-12-29, 11:01
Member
6 posts

Registered:
Feb 2006
First I'd like to thank you for supporting the Mac community. More and more people are migrating to Mac and I think it's great we have a version to play Quake.

I installed everything needed to get the app running on my MacBook. For some reason the screen is stretched vertically when I load into a game from the console...I tried playing at different resolutions but that did not work. How do I fix this problem?

Have you put any thought into porting Qrack to a Mac Universal binary? Qrack is the best NQ Quake engine to date.
2006-12-29, 11:22
Member
4 posts

Registered:
Dec 2006
Tuna wrote:
i have installed the above libraries through macports. with that i was able to see the splash menu. however when i try to click "play" i do get an error. running from the terminal the exact error is:
./EZQuake-GL.app/Contents/MacOS/EZQuake-GL
EZQuake-GL(433,0xa000ed88) malloc: *** vm_allocate(size=3630071808) failed (error code=3)
EZQuake-GL(433,0xa000ed88) malloc: *** error: can't allocate region
EZQuake-GL(433,0xa000ed88) malloc: *** set a breakpoint in szone_error to debug
2006-12-29 11:25:17.544 EZQuake-GL[433] An error has occured: Q_malloc: Not enough memory free; check disk space

any ideas what may be wrong? the allocation size seems a bit high?

Same here. But the earlier version works fine...
2006-12-30, 09:42
Member
62 posts

Registered:
Jan 2006
woods wrote:
First I'd like to thank you for supporting the Mac community. More and more people are migrating to Mac and I think it's great we have a version to play Quake.

I installed everything needed to get the app running on my MacBook. For some reason the screen is stretched vertically when I load into a game from the console...I tried playing at different resolutions but that did not work. How do I fix this problem?

Have you put any thought into porting Qrack to a Mac Universal binary? Qrack is the best NQ Quake engine to date.

I had the same problem when i first started EZQuake, just change your -conwidth and -conheight in your startupline.
I play with -conwidth 320 -conheight -240

I hope it works for you, gl!
2006-12-30, 09:44
Member
62 posts

Registered:
Jan 2006
Tuna wrote:
i have installed the above libraries through macports. with that i was able to see the splash menu. however when i try to click "play" i do get an error. running from the terminal the exact error is:
./EZQuake-GL.app/Contents/MacOS/EZQuake-GL
EZQuake-GL(433,0xa000ed88) malloc: *** vm_allocate(size=3630071808) failed (error code=3)
EZQuake-GL(433,0xa000ed88) malloc: *** error: can't allocate region
EZQuake-GL(433,0xa000ed88) malloc: *** set a breakpoint in szone_error to debug
2006-12-29 11:25:17.544 EZQuake-GL[433] An error has occured: Q_malloc: Not enough memory free; check disk space

any ideas what may be wrong? the allocation size seems a bit high?

Maby you shoudnt install the libaries through macports? Thats the only difference between my and you're libaries, and I suppose you have an IntelMac?
2006-12-30, 10:57
Member
1011 posts

Registered:
Feb 2006
all the libraries you need are in ./EZQuake-GL/Contents/SharedSupport/
you just need to setup symbolic links in /opt/local/lib using the generic names required by the binary
2006-12-30, 19:48
Member
341 posts

Registered:
Nov 2006
i temporarily moved my macport created libs to another directory and filled up the new empty lib dir with the libs found in the .app. i have created the needed symlinks but the error persists with these libs too

EDIT: i did some quick debugging and apparently the error occurs when it tries to read id1/pak0.pak. found the following infos in the backtrace of FS_LoadPackFile:
header = {
id = "PACK",
dirofs = 1468667393,
dirlen = -1068236800
}

i wonder if those numbers are correct. maybe this release is using wrong byteorder conversion for some reason? when look at the first number and make a byte conversion i end up in a number at around 18mio.. which could represent 18mb which indeed pak0.pak is in size.
2006-12-31, 20:28
Member
1011 posts

Registered:
Feb 2006
yes looks like the endian swapping for the PPC version hasn't worked i'll release a fixed version asap in the new year
2007-01-08, 04:14
Member
58 posts

Registered:
Feb 2006
any word on this fixed version, oldman?
finem respice
2007-01-10, 22:02
Administrator
2058 posts

Registered:
Jan 2006
Quote:
#3 ./configure --mandir/usr/local/share/man/CFLAGS=-02

should be:

#3 ./configure --mandir /usr/local/share/man/ CFLAGS=-02
2007-01-11, 10:37
Member
62 posts

Registered:
Jan 2006
fixed Empezar. Thanks.
2007-01-11, 10:37
Member
62 posts

Registered:
Jan 2006
Oldman: any news about the new compile?
2007-01-12, 11:55
Member
1011 posts

Registered:
Feb 2006
hopefully fixed version available here
  20 posts on 1 page  1