User panel stuff on forum
  2 posts on 1 page  1
Help
2017-04-13, 16:50
Member
1 post

Registered:
Apr 2017
Hi, I'm on Ubuntu Mate 16.10 64bit.
What am I supposed to install when this error shows up?

I already solved some problems.

Quote:
./ezquake-linux-x86_64: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

For this I installed libsdl2-2.0-0

Quote:
./ezquake-linux-x86_64: error while loading shared libraries: libpcre.so.1: cannot open shared object file: No such file or directory

For this I had to symlink a library I had already installed (libpcre3):
sudo ln -s /lib/x86_64-linux-gnu/libpcre.so.3 /usr/lib/x86_64-linux-gnu/libpcre.so.1


Quote:
./ezquake-linux-x86_64: error while loading shared libraries: libjansson.so.4: cannot open shared object file: No such file or directory

sudo apt-get install libjansson4


But now I'm stuck with that libcurl problem.

Thanks for your time
2017-04-14, 15:47
Administrator
160 posts

Registered:
Sep 2015
I'm really not a linux expert, but check out https://github.com/ezQuake/ezquake-source/blob/master/COMPILING_ON_LINUX.txt. We'd always recommend compiling from source on non-Windows machines.

From the looks of the instructions, maybe missing libcurl4-openssl-dev?
  2 posts on 1 page  1