User panel stuff on forum
  10 posts on 1 page  1
Server Talk
2011-09-21, 06:34
Member
5 posts

Registered:
Sep 2011
Hi, so I have been tasked with setting up a CTF server for the remaining NZ Quake community and I thought I had it all sorted, but upon launching tonight have encountered some teething issues I need help to resolve.

I am running the latest KTX/MVDSV.

First issue is that when players join a game in progress, by setting team outside the game then connecting, they are spawning without team colors. If they try to change color team colors are enforced (top changes but pants go to the team color they are suppose to be) but if no change is made they remain white. They are killable by the opposite team.

Second issue, I am not using the custom CTF flag and grapple models (nostalgia) however when someone carries the "flag" it does not hover around them, instead they just glow, making it very hard to pick out the flag carrier.

Third issue is the quad respawns, these things are back every two minutes, I would prefer at least a five minute cooldown but am not sure how to implement this.

Any help much appreciated.
2011-09-21, 10:30
Administrator
1214 posts

Registered:
Jan 2006
questions arent so easy.
can you tell what ctf version you installed on the server?
pure ctf? which version?

question number 2 seems like a client configuration issue.

http://wiki.quakeworld.nu/Ctf
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2011-09-21, 22:48
Member
405 posts

Registered:
Jan 2006
1) Colors issue I fixed in KTX this night, get it from git, at least you get proper colors while connecting during active game.
2) No idea about models.
3) Quad respawn time is 60 seconds, not configureable, have no idea which respawn time was back in the days, I can point at sources where you have to change few lines of code for that but not sure if it really a good idea.
<3
2011-09-22, 00:04
Member
5 posts

Registered:
Sep 2011
WOW thanks heaps man that is awesome

We are going to use the ctf models so I will let you know how that works out.

On our servers we had it set to 5 minutes, I'm not sure what mod we were running but it can become an issue on popular (at least down here in little NZ) ctf maps such as Elder God Shrine where 4 quads respawning every 60 seconds is overwhelming.

Really appreciate the prompt fix and response, we are having our first official open game night on the server tonight so its come just in time.
2011-09-22, 03:44
Member
5 posts

Registered:
Sep 2011
qqshka, we are still experiencing the issue with team colors not being assigned when players join mid match. Also tossflag causes the flag to drop but you also lose every weapon you are carrying including the grapple. Thanks again for your assistance I know these things can be difficult to resolve
2011-09-22, 20:47
Member
405 posts

Registered:
Jan 2006
Mojo wrote:
qqshka, we are still experiencing the issue with team colors not being assigned when players join mid match. Also tossflag causes the flag to drop but you also lose every weapon you are carrying including the grapple. Thanks again for your assistance I know these things can be difficult to resolve

1) About colors. Did you get KTX from git? Something like "git clone http://qw-dev.net/git/ktx". Or get it precompiled here http://builds.qw-dev.net/ktx/ Since I checked it few times and get proper colors, well, you can change topcolor mid game but bottomcolor are locked to team (red or blue).

2) tossflag are fixed too.
<3
2011-09-23, 04:15
Member
5 posts

Registered:
Sep 2011
My bad man, I downloaded the latest x86 release and didn't check the build date, got the os independent latest version now and things are sweet
Sorry for implying your awesome fix hadn't worked

While I have your attention, is it possible to have players disconnect completely (ie. not get the yellow dot next to their name remembering their score), can this feature be disabled ?
The ability to change teams mid match would also be handy for players. At the moment they have to disconnect, change name, then change team and reconnect. We will be playing again tonight so will let you know if any other bugs arise. Thanks again.
2011-09-26, 17:47
Member
405 posts

Registered:
Jan 2006
Mojo wrote:
While I have your attention, is it possible to have players disconnect completely (ie. not get the yellow dot next to their name remembering their score), can this feature be disabled ?
The ability to change teams mid match would also be handy for players. At the moment they have to disconnect, change name, then change team and reconnect. We will be playing again tonight so will let you know if any other bugs arise. Thanks again.

There is "lockmode" command, or you can try put in the file "ktx\configs\usermodes\ctf\default.cfg" one line, "set k_lockmode 0". And get new KTX from buildbot since I did some changes, *sigh*

This will partially solve issue: there will be no ghost in the scores, but you still need to disconnect before you change team, but at least you must NOT change name.
<3
2011-09-30, 21:35
Member
5 posts

Registered:
Sep 2011
Thanks qqshka thats exactly what I needed

We noticed on Thursday nights game that some maps aren't behaving right, for instance on e1m1 the secret door in the blue base is functioning, likewise the underwater passage in e1m2 from the red base to the RL is also opening when it shouldn't.
Thanks again for your help, I'm still getting asked about 5 minute quad timing so I might have to consider compiling ktx myself as you suggested.
2011-10-03, 06:24
Member
405 posts

Registered:
Jan 2006
doors should be fixed now...
<3
  10 posts on 1 page  1