User panel stuff on forum
  12 posts on 1 page  1
General Discussion
2010-02-10, 16:05
Administrator
1212 posts

Registered:
Jan 2006
Hi,

I didnt install linux for some time, i did it again this week.
Actually it instantly recognized my hardware, and i tried quake, it didnt felt bad. actually it felt quite responsive. i also tried quakelive, mouse felt better than qw.
Ive got the 500hz mouse hack.

Now im struggling to have my beloved 154hz @ 800x600.
I followed some guides available on the net, but i cant change it from 85hz

in desktop resolution i sucessfully imported windows powerstrip modeline (1600x1200 76hz)
i also imported windows powerstrip modeline 800x600 154hz. but it didnt work, neither ingame nor in desktop environment

So the questions:
1) basically i want to get 1600x1200 76hz in desktop AND 800x600 154hz, like i have in windows.
2) which in_mouse is better in linux? ive heard raw input is better, and already tried it. felt a bit better.

help?

im using last ubuntu
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2010-02-10, 17:34
Member
206 posts

Registered:
Jan 2006
you can use a program called gtf to calculate resolution and horiz and verisync for X.
you can add new modes with xrandr. read the man file for xrandr and you will easily figure out how to conquer your quest!

It's really not that hard and anyone should be able to add resolutions etc to x.
2010-02-10, 18:00
Administrator
1212 posts

Registered:
Jan 2006
ive added modelines to xrandr sucessfully
but somehow it isnt applyed ingame
plz help
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2010-02-10, 18:38
Member
10 posts

Registered:
Oct 2009
Have you restarted X after adding the modelines mushi? and as for your mouse question, evdev mouse (in_mouse 3) $$$$$$$$$$$$$
2010-02-12, 15:43
Administrator
1212 posts

Registered:
Jan 2006
yes i did.

Ive been trying to add other resolutions such as 1024x768 100hz, 800x600 100hz, 640x480 100hz/120hz/150hz, etc.
without success, same error:

xrandr: Configure crtc 0 failed


I am at a dead end. i cant get "custom"hz to work, not even 100, 120 or 160hz....
i have set correct modes on xrandr.

here is my xorg.conf:


$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Thu Jun 25 18:57:07 PD T 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 95.0
VertRefresh 30.0 - 170.0
Option "DPMS"
ModeLine "1600x1200" 201.690 1600 1672 1864 2144 1200 1201 1204 1250 + hsync
Modeline "800x600_153.00" 110.81 800 864 952 1104 600 601 604 656 -HSync +Vsync
Option "PreferredMode" "1600x1200"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "800x600_153" "6 40x480"
EndSubSection
EndSection
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2010-02-12, 15:55
Member
1099 posts

Registered:
Jan 2006
I don't use a real xorg.conf, no modes in it, only basic stuff about other things. xrandr lists a ton of modes which I can use fine.
xrandr -s 320x240 works fine. I use Archlinux, nvidia 190.53 and XFCE (its display options shows all those modes too).

What does xrandr list?
2010-02-13, 18:52
Member
2 posts

Registered:
Feb 2010
Try to add some options to your xorg.conf such as:
Option "UseEdidFreqs" "false"
Option "ExactModeTimingsDVI" "true"
and then load nvidia-settings app each time after starting X server

also look in your /var/log/Xorg.0.log for errors and modes validation
2010-02-14, 17:16
Administrator
1212 posts

Registered:
Jan 2006
Still can't do it.

Here is my xrandr list, with only one custom resolution defined (800x600_153)


mushi@mushi-desktop:~$ xrandr
Screen 0: minimum 320 x 175, current 1600 x 1200, maximum 1600 x 1200
default connected 1600x1200+0+0 0mm x 0mm
1600x1200 50.0* 55.0 56.0 57.0 58.0
1280x1024 51.0 67.0 68.0
1024x768 52.0 79.0 80.0 81.0 82.0 83.0
800x600 53.0 95.0 96.0 97.0 98.0 99.0 100.0 101.0 102.0 103.0
640x480 54.0 112.0 113.0 114.0 115.0 116.0
1600x1024 59.0
1440x900 60.0
1400x1050 61.0 62.0 63.0 64.0
1360x768 65.0 66.0
1280x960 69.0 70.0 71.0
1152x864 72.0 73.0 74.0 75.0 76.0 77.0 78.0
960x720 84.0
960x600 85.0
960x540 86.0
928x696 87.0
896x672 88.0
840x525 89.0 90.0 91.0 92.0 93.0
832x624 94.0
800x512 104.0
720x450 105.0
720x400 106.0
680x384 107.0 108.0
640x512 109.0 110.0 111.0
640x400 117.0
640x350 118.0
576x432 119.0 120.0 121.0 122.0 123.0 124.0 125.0
512x384 126.0 127.0 128.0 129.0 130.0
416x312 131.0
400x300 132.0 133.0 134.0 135.0 136.0
360x200 137.0
320x240 138.0 139.0 140.0 141.0
320x200 142.0
320x175 143.0
800x600_153.00 153.0
mushi@mushi-desktop:~$



switching to my custom resolution:
mushi@mushi-desktop:~$ xrandr --addmode default 800x600_153.00
mushi@mushi-desktop:~$ xrandr --output default --mode 800x600_153.00
xrandr: Configure crtc 0 failed

what happens in certain modes is that i set them with xrandr -s and it seems to work (screen flickers). when i check the "real" hz from my monitor's OSD, it isnt the same!
for example:
mushi@mushi-desktop:~$ xrandr -s 640x480 --rate 112
OSD shows 85hz

mushi@mushi-desktop:~$ xrandr -s 1024x768 --rate 82
OSD shows 60hz


I really dunno what to do, ive searched alot
QW isnt smooth enough, i want my windowze 154hz
help
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2010-02-14, 19:42
Member
1099 posts

Registered:
Jan 2006
Oops, I mixed the two linux threads in my head. Sorry.

No idea about the frequency stuff. I use a TFT so I don't bother with that.
2010-02-15, 01:20
Member
188 posts

Registered:
Jan 2007
Solved on IRC. For anyone else running into something like this, just add the generated modelines without any postfixes, and get rid of the 'Modes' line in the 'Screen' section - it's fairly pointless anyway.

Here's the final x.org.conf for reference:
Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Thu Jun 25 18:57:07 PDT 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

# Wrong place for those two anyway.
# Option "UseEdidFreqs" "false"
# Option "ExactModeTimingsDVI" "true"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 96.0
VertRefresh 30.0 - 170.0
Option "DPMS"
Option "PreferredMode" "1600x1200"
Modeline "640x480" 69.99 640 680 752 864 480 481 484 526 -HSync +Vsync
Modeline "800x600" 103.02 800 856 944 1088 600 601 604 653 -HSync +Vsync
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
2010-02-15, 01:53
Administrator
1212 posts

Registered:
Jan 2006
yes, it is solved.
thx bigfoot

was alot easier than i expected. i suspected it wouldnt work... it did linux rocks!
never argue with an idiot. they'll bring you back to their level and then beat you with experience.
2010-03-22, 13:35
Member
705 posts

Registered:
Feb 2006
How is it "not installing" ?
please be more specific.
  12 posts on 1 page  1